ColdFusion support in WebStorm?

How do I install the JetBrains ColdFusion plugin into WebStorm?  IntelliJ IDEA apparently has that plugin available to it, and I assume IDEA and WebStorm must use the same plugin "language" no?  So it should work in WebStorm, I would imagine.  Can someone point me to the appropriate repository, so WebStorm will download and install it?

Thanks...

16 comments
Comment actions Permalink

CFML plugin is only available in Intellij IDEA, and it can't be installed in WebStorm.

The plugin is open source  - see https://youtrack.jetbrains.com/issue/IDEA-83102#comment=27-633162. So, you can probably re-write it to avoid dependencies on plugins missing in WebStorm to make it compatible with this product. Or, develop your own plugin that would provide similar functionality.
Source code of the CFML plugin is available with Apache 2 style license.
Here is the introduction for developing such plugins in IntelliJ Idea https://confluence.jetbrains.com/display/IDEADEV/Developing+Custom+Language+Plugins+for+IntelliJ+IDEA

 

If all you need is some basic syntax highlighting, you can either create a new file type in Settings/Editor/File Types, add .cfml as a registered pattern there, and define your own syntax highlighting rules, or search for existing textmate bundles for CFML on the web, import them and use for the .cfml syntax highlighting - see http://blog.jetbrains.com/phpstorm/2013/05/textmate-bundles-in-phpstorm/ and http://stackoverflow.com/a/16451778/2000323 for more info.

2
Comment actions Permalink

Oh, wow - that’s a lot of information. Thank you so much! I’m sure I can get something working.

I’m just tired of using two separate IDEs - one for Angular 2, JavaScript, HTML, etc., and a whole separate one for ColdFusion. (And CF Builder 3 from Adobe is an unreliable, buggy p.o.s. anyway. The only reason I use it is that it came for free when we bought our ColdFusion licenses.)

I think your suggestions will be very helpful. Thanks so much.

0
Comment actions Permalink

Well, I can't get the ColdFusion Textmate file to import properly...  Or even the Ruby one that you linked here: http://stackoverflow.com/a/16451778/2000323

In that StackOverflow article, his instructions say to look at the "File Types" then "Files Supported via Textmate bundles" and under that should be the file-types associated with the Textmate bundle...  But on mine, I don't have "Files Supported via Textmate bundles" showing under "File Types".  It *should* be right after "Files opened in associated applications" (which I *do* have), but it's not there at all.

Thinking that there might be an issue with the ColdFusion Textmate bundle, I imported the Ruby Textmate bundle, exactly like in his example.  I checked the appropriate .plist file and made sure the <string>rb</string>" tag was there.  But even after importing that Ruby Textmate file, I still don't see "Files Supported via Textmate bundles."  So how do I get that to appear?  Or, if it's not going to be there in WebStorm, where is it?  Or, how do I *manually* associate a file type with a Textmate bundle?

To clarify -- I get no error messages when importing either the ColdFusion Textmate bundle, or the Ruby Textmate bundle.  Both of them *claim* to be installed correctly.  But I see no file-types associated with either one.  The ColdFusion bundle does *not* have the <key>filetype</key> tag anywhere in it, but the Ruby bundle *does* have that tag, and I still get no associated file-types in WebStorm, like the PhpStorm example shows.

Oh, and I *am* closing WebStorm and re-opening it after installing the Textmate bundle, too, btw...

Any help will be appreciated.

Thanks,
L.

 

0
Comment actions Permalink

This file type was remoived when fixing https://youtrack.jetbrains.com/issue/RUBY-13617.... Currently the extension should be assigned automatically when installing the textmate bundle. And it does work for me (at least it works for Ruby bundle):

0
Comment actions Permalink

HA!  Silly me...  I got all hung up on not being able to see the file-types in WebStorm, that I never even *tried* to use the TextMate bundles as intended...

Looks like both the ColdFusion and the Ruby bundles work as intended...  Cool.

Next question -- how do I change the color-scheme that the ColdFusion bundle uses?  How do I tell which color scheme it's using now?

Thanks!
L.

 

0
Comment actions Permalink

Colors/styles of characters in TMbundle are managed via scopes which are assigned by a regexp in bundle definition. How this scope will be drawn is defined in the color theme. WebStorm bundles standard TextMate themes ("\plugins\textmate\lib\themes"). For each bundle, you can choose a textmate theme to be used - for this, you have to map the  TextMate color scheme to your current editor color scheme. For example, you have Default chosen in Settings | Editor | Color Scheme - then in Settings | Editor | TextMate Bundles you have to choose a textmate scheme for default IDE color scheme:

0
Comment actions Permalink

Under Preferences | Editor | Color Scheme, it says I am using the Darcula color scheme.

Under Preferences | Editor | TextMate Bundles I have *all* of the IDE color schemes mapped to "Darcula" and I'm still getting this crazy color-scheme in the ColdFusion TextMate bundle -- white background with blue and green and grey text, and the line the cursor is on is so dark that you can't read it.

So apparently the ColdFusion TextMate bundle is either not using a built-in IDE color-scheme, or is somehow defining the colors in some other way.  Any ideas on how to change it?

Thanks,
L.

 

0
Comment actions Permalink

Likely a problem of cf bundle - looks like standard textmate themes don't contain all scope selectors defined in it...

0
Comment actions Permalink

Just for kicks, I used my Mac's TextEdit program to type in the contents of the "test.rb" file shown on that StackOverflow page...  Saved it to my desktop as 'test.rb'.  Then, in WebStorm, I clicked "File | Open" and I opened that 'test.rb' file.

And it's using the same horrible color-scheme as the ColdFusion tmbundle is....

So it's either a problem with *both* tmbundles, or there's something set wrong in my WebStorm installation somehow...

How do I manually tell WebStorm to use a particular color-scheme for a particular file-type?

Thanks,
L.

 

0
Comment actions Permalink

>How do I manually tell WebStorm to use a particular color-scheme for a particular file-type?

it's not possible

>So it's either a problem with *both* tmbundles, or there's something set wrong in my WebStorm installation somehow...

 

Ruby bundle works fine for me...here is what it looks like with `Darcula` TM theme chosen:

 

0
Comment actions Permalink

Here's something else interesting...   I tried creating my own ColdFusion file-type...  So in Preferences | Editor | File Types, I clicked on the + and entered ColdFusion in the name field and ColdFusion CFC and CFM in the description.  Then I clicked OK.  Then in the Registered Patterns area, I clicked the plus sign, and typed *.cfc into the Add Wildcard field.  I got the following error message: "This wildcard s reserved for 'Files Supported via Textmate bundles' filetype and cannot be reassigned".  So that Files Supported via Textmate bundles" file type *is* there -- it's just not visible.

How do I make it visible?  So I can maybe see how it's associated with a color scheme, perhaps?

Thanks,
L.

 

0
Comment actions Permalink

Here's what my Preferences | Editor | TextMate Bundles looks like:

And here's what 'test.rb' looks like:

So what am I doing wrong?

Thanks,
L.

 

 

0
Comment actions Permalink

>So that Files Supported via Textmate bundles" file type *is* there -- it's just not visible.

yes, that's expected - file extensions listed in Tmbundle syntaxes fileTypes array are implicitly associated with "Files Supported via Textmate bundles" file type

>How do I make it visible?  So I can maybe see how it's associated with a color scheme, perhaps?

No way to see this in UI. and the way certains code construction is assigned to scope, and scope - to color can only be seen in bundle files

 

>here's what 'test.rb' looks like

does the issue persist if you disable ColdFusion bundle? BTW, what bundles do you use? Can you share the links?

0
Comment actions Permalink

I deleted the ColdFusion bundle entirely, and the issue still persists...  Very weird... 

Here are the links to the repositories from which I cloned the tmbundles:
Ruby: https://github.com/textmate/ruby.tmbundle
ColdFusion: https://github.com/textmate/coldfusion.tmbundle

Thanks for any help you can offer.
L.

 

0
Comment actions Permalink

works fine for me using your bundles... Please can you search for textmate.xml file in your WebStorm config directory (https://intellij-support.jetbrains.com/hc/en-us/articles/206544519-Directories-used-by-the-IDE-to-store-settings-caches-plugins-and-logs) and provide the file?

0
Comment actions Permalink

Got busy with work and didn't have time to check out your latest suggestion -- so sorry for the delay...  I finally remembered to do it...  Here are the contents of my textmate.xml file

<application>
  <component name="TextMateSettings">
    <option name="bundles">
      <list>
        <BundleConfigBean>
          <option name="name" value="Ruby" />
          <option name="path" value="$APPLICATION_PLUGINS_DIR$/ruby.tmbundle" />
        </BundleConfigBean>
        <BundleConfigBean>
          <option name="name" value="ColdFusion" />
          <option name="path" value="$APPLICATION_PLUGINS_DIR$/coldfusion.tmbundle" />
        </BundleConfigBean>
      </list>
    </option>
    <option name="themesMapping">
      <map>
       <entry key="All hallow's eve" value="Darcula" />
       <entry key="Blackboard" value="Darcula" />
       <entry key="Cobalt" value="Darcula" />
       <entry key="Darcula" value="Darcula" />
       <entry key="Default" value="Darcula" />
       <entry key="Monokai" value="Darcula" />
       <entry key="Programmer" value="Darcula" />
       <entry key="Railscasts" value="Darcula" />
       <entry key="Twilight" value="Darcula" />
       <entry key="VibrantInk" value="Darcula" />
       <entry key="WarmNeon" value="Darcula" />
        <entry key="_@user_Darcula" value="Mac Classic" />
      </map>
    </option>
  </component>
</application>

In that last entry-key tag, I changed the value to "Darcula" and now the .tmbundles work as expected!!  Don't know why this key is there, but clearly that has been the problem all along.  I did try deleting the key entirely and the program just re-created it the next time I loaded a .rb or .cfc file...  But changing it from "Mac Classic" to "Darcula" fixed it.  Now I'll change the others back to what they were before, just so they're set up properly.

Thanks so much for your help!

L.

 

0

Please sign in to leave a comment.