"Find in Path" Window Refuses to Move To Other Monitor


I have a dual-monitor setup running CLion under LinuxMint 18.

Lately I've noticed that when I do a Ctrl-Alt-F search for something, the resulting "Find in Path" window can be moved around on the monitor it happens to pop up on (often not the one the CLion instance is visible on), but cannot be moved to the other screen.

This becomes very inconvenient when I want to visually compare the results to information in a different window. I can move all other windows around across both monitors just fine, for example, another instance of CLion for a different project (just not _it's_ "Find in Path" window; it's locked to the single monitor _IT_ came up on).

XX Not sure if it's related, but the pin button doesn't seem to do anything but change the pin button's background from light to dark. Edit: Figured out that the pin button keeps the Find window from closing when you navigate to one of the matches.

CLion 2017.3.3
Build #CL-173.4548.31, built on January 30, 2018
JRE: 1.8.0_152-release-1024-b11 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.4.0-62-generic


Hi! Unfortunately, I can't reproduce the issue (at least on my macOS machine with CLion 2017.3.4 EAP): I can move the "Find in Path" results window to the other screen.

Please try the latest 2018.1 EAP and, if the issue still occurs in it, report it to the platform tracker: https://youtrack.jetbrains.com/issues/IDEA.


Problem persists in 2018.1 EAP.


Hah! I managed to fix it. I was playing around with it, resizing the "Find in Path" window, and noticed that while I was able to change the width, the top and bottom edges of the window were 'glued' to the screen edges, i.e. the resize icon wouldn't appear when hovering at the top or bottom edge of the window.

I clicked "Open in Find Window", which opened that search in the bottom area of the main CLion window. The next time I did a "Find in Path" I was able to adjust the height of the window, then was able to move it freely around both monitors.

Bizarre to say the least, but no longer an issue. Thanks for having a look at it!


Thanks for sharing your solution!


Thanks for the solution imbs - I was going mental because of that (unable to resize, or move it to another monitor). It's all good after I clicked "Open in Find Window".


Unluckily, but this solution didn't work out in my case. I still can't move this damn 'Find in Path' window from my second monitor and it drives me crazy.

My operation system is Ubuntu 17.10

PyCharm 2018.1.2 (Professional Edition)
Build #PY-181.4668.75, built on April 25, 2018
JRE: 1.8.0_152-release-1136-b29 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.13.0-39-generic


@Andrei please report the issue to the platform tracker: https://youtrack.jetbrains.com/issues/IDEA.


@Andrei, the issue is recurring for me, and I don't know how to reproduce it. But try to have only one instance of IDE open and click "Open in Find Window" with a mouse (not Ctrl + Enter shortcut).


@Jerzy, yes, I tried both variants, but none of them helped.

@Anna, reported this issue to the tracker. 


@Andrei, thanks a lot! I post the link to the created issue here so that other users can upvote it: https://youtrack.jetbrains.com/issue/PY-30022.


I have similar problem - my "Find in path" popup opened in different monitor, but I'm like to use it in main monitor. I can't resize and move popup.

Webstorm 2018.1.4 on Debian GNU/Linux 8 (jessie) 64-bit, Gnome 3.14.1


@Eugene, please comment https://youtrack.jetbrains.com/issue/IDEA-192093 and follow it to get updates.


@Anna, I have no permissions for this issue. Relogin not helps.


@Eugene, sorry, haven't noticed that the user made it private. Will ask him whether we can open it. Here is the similar issue - https://youtrack.jetbrains.com/issue/IDEA-191111. You can leave your comment there.   


Happening to me too. Mac OS 10.13.5

The linked issue is about oversized window. This is not related to my issue: I can't get the find window to move to the same monitor that WS is in. 

Tried moving WS to the lower monitor, then back to the upper, then opening FInd in Path but the find window is still stuck on the lower monitor. 


WebStorm 2018.1.5
Build #WS-181.5281.31, built on June 14, 2018
Subscription is active until August 1, 2018
JRE: 1.8.0_152-release-1136-b39 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.5


Justin, I made https://youtrack.jetbrains.com/issue/IDEA-192093 visible for everyone. It's about moving the "Find in path" window. Please comment or upvote.


Had the same issue -- after trying the "Open in Find Window" click, still didn't seem to be solved.

Next time I did Find in Path, though, I was able to resize the top, right, and bottom away from the monitor edges and this finally let me move the window.


A bit late to the party but I was experiencing this issue on Ubuntu 18.04 LTS with RubyMine.
As dexcribed above the find window was stuck on my second monitor and outstreatched my view limits.
After reading this thread I fixed the issue by moving my IDE to the second monitor and expanding the ide to full screen.  Then i reoponed the find window and it was now within the boundries of the monitor.   After moving the IDE back to my main monitor and reopening the find window i was now able to grab and relocate the find window to my primary monitor.  
Hope this helps.


I'm solving it (on Ubuntu 18.04) exactly in the same way Allan describes. For me the problem occurs only if my secondary monitor has smaller resolution than the primary one.


Allan's solution worked for me, thank you!

I had the problem when my IDE was on my large monitor, but the find window kept on appearing on the laptop monitor and couldn't be resized/moved. Attempts to use alt-F7 on ubuntu ended up moving the IDE window instead of the find window. I was able to resolve the issue with Allan's solution by moving my IDE to my laptop monitor, expanding to full screen, and reopening the find window. It was only at that point that I was able to resize/relocate the find window.


Same issue on Ubuntu 18.04. I have two identical monitors with the same resolution. I accidentally moved the window to another monitor and it refuses to go back. Probably a problem arises, with a non-standard prioterization of the first and second monitor.


I got Windows 10. I use 3 screens, working with Intellij in secondary screen 2, and my "Find in path" was locked in screen 1 (primary display).
Solution was to change screen 2 to primary display, then "Find in path" opened in screen 2 (correct). After resetting primary display to screen 1, "Find in path" still opens in screen 2. 


Thanks imbs, I had the same issue in PyCharm, your solution worked for me.


Oh man Irfan Blackhawk take it easy. There's a solution posted here. When you say "most ___ in history of ____" you sound histrionic. 


@collum its not IDE issue.

Thanks for your support.

For any one whose is finding difficulty due GPG key pasted "find in path" refer below link.



I fixed this issue in Clion 2018.3 by:

  • Closing all app instances.
  • Deleting the following file: /home/<user>/.CLion2018.3/config/options/dimensions.xml

It looks like this settings file is used to store the last known locations of dialog boxes/popups. I'm going to hazard a guess that the "find.popup" entry is given a state that the IDE can't deal with properly.


I fixed this by resizing it, dragging the appropriate edge of the tool window onto the monitor that I wanted it on and then dragging the remaining side over to the same monitor. 



Resizing the window allowed me to drag it to the other screen, thanks for the workaround.

Ubuntu 18.04

CLion 2019.1
Build #CL-191.6183.77 built on March 25, 2019


Hello guys

This bug is still present on my environment : Intellij 2019.1 Build #IU-191.6707.61 built April, 16 2019

I have 3 screens : screen of my labtop and 2 other (much bigger). By error I have move "find search" window on labtop and now IMPOSSIBLE to put it back on one of the 2 other monitor... I have try all what is indicate in this post and impossible to fix it ! I have look for any parameter on any configuration file, but found nothing !

So please could you help me ?



Please sign in to leave a comment.