Pycharm debugger doesn't stop at any breakpoint


I setup a tox project in my pycharm, but it never stop at any breakpoints during debugging. The command it generates at the beginning of the debugging process is 

C:\Python27\python.exe "C:\Program Files\JetBrains\PyCharm Community Edition 2017.3\helpers\pydev\" --multiproc --qt-support=auto --client --port 62895 --file "C:\Program Files\JetBrains\PyCharm Community Edition 2017.3\helpers\pycharm\"
pydev debugger: process 6628 is connecting


I'm running a luigi pipeline project in windows, pycharm version is 2017.3 community version. I have already restarted pycharm a couple of times. 

Appreciate if anyone can advise. 


Jamawadi Noor's suggestion to disable gevent also worked for me


Hey guys,


I am using Pycharm professional 2019.3.1.

Disabling the gevent actually works.

But, I have a situation where I have to debug two processes simultaneously,

One process should use the gevent option and one isn't.


My workaround is pretty stupid:

  1. Uncheck the gevent checkbox.
  2. Start debugging process X which is getting messed up by the gevent option.
  3. Check the gevent checkbox.
  4. Start debugging process Y which need the gevent option.


Now debugging works and hits all breakpoints in both of them!


To Pycharm team - Please provide a better solution for it - maybe something like an environment variable "GEVENT_SUPPORT" which can be used in each debug configuration separately and thus not needing this stupid workaround.


With Appreciation,




Second Mickey's request - i have a similar use case and it would be a god send...


Same issue here: I've written a custom management command, and when I run in debug mode it'll honor breakpoints up in the Command class, but not in print statements (or anything else) in the add_arguments or handle methods. No difference after renaming my .idea folder and restarting PyCharm, and my Preferences/Python Debugger never had "Gevent compatible" selected. 

Other ideas to try?


Had a similar issue in Pycharm 2020.3, Pycharm not stopping on any breakpoints in flask callbacks.  Unchecking "Gevent compatilble" in Pycharm settings (under Python Debugger) solved the issue.  Hope this helps.


I have fixed my business macbook with an old comment that I have posted here but for my personnal macbook, impossible to fix this issue...

Pycharm : 2019.1.4 PRO

Delete the project, gevent disable, nothing works for me !


This issues happened after I rebooted my computer. One of my project can't stop at any breakpoints. However, the others still work.

Can't figure out what causes this problem. Remove the python interpreter environment of the project and reinstall one, it works then.



I have created an issue and the result of all the tests seems to be that the 2019.1.4 PRO version is BUGGYYY.

It's works with the latest version of Pycharm CE (2020.2.2)...

So now that I have stop the payment of my ALL Licence pack because this bug make me crazy one my 2 computers and make me loose 2/3 days of production, I can't update the version and I will see what will be the jetbrains response for this use case.


In my case, I deleted the config folder and .idea in the work folder. After then breakpoints works fine.


I had same problem with latest version. Renaming the .py file to an alternate name and then back again solved the problem.


PyCharm 2020.2.3 (Community Edition)
Build #PC-202.7660.27, built on October 6, 2020
Runtime version: 11.0.8+10-b944.34 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 10.15.7


As Pedrohrfp suggested disabling coverage helped in my case. I did it passing '--no-cov' as 'additional argument' in pytest run/debug configuration. I'm using IntelliJ IDEA not PyCharm though.


Please sign in to leave a comment.