Schema is not updating


Using Datagrip 2017.3.7

Using Oracle, and I have Auto Sync on.

Working on a small schema, with about 15 tables and 15 views.

I sync manually, but the schema is not synced. Views that have been deleted still show up under View folder. If I do a ctrl+Q I will still get up the  DDL for the view.

I view the same schema in TOAD, and there are none of the views that have been deleted.

Please fix this, as this is potentially dangerous.


Same here. Pretty big Redshift cluster, probably 50 tables. Stuck in the refresh mode forever

DataGrip 2021.2.3
Build #DB-212.5457.16, built on September 28, 2021
Licensed to Amazon Corporate, LLC

Runtime version: 11.0.12+7-b1504.40 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 10.14.6
GC: G1 Young Generation, G1 Old Generation
Memory: 2048M
Cores: 4


@Lchu is it withing the same transaction? It looks like you're making changes in different transactions


I've faced the similar issue.

Database Tools and SQL plugin 222.4345.14 for IU 2022.2.3. Datasource type: Android SQLite.

My actions:

 - On datasource: "Forget cached schemas"

 - On datasource: "Force refresh" or "Refresh" (tried both)

 - On "main" schema: "Refresh" or "Diagnostic Refresh" (tried both)

Eventually, trying all combinatoins, I'm getting notification "Data Source Synchronization. 'DATASOURCE_NAME': Up to date. Skipping."

Hence data inside android emulator and in idea keeps being different.

How can I not "Skip"  "Data Source Synchronization", but drop this "Up to date" and cached somewhere data?


Vadim Shabanov, please, check if you meet the same problem as described in this bug report in our YouTrack.
Also, please, try to update your IntelliJIDEA to the latest available release 2022.3.1, and check if the problem persists.


Olga Mulina Similar, but not quiet. I've described my situation here:


I believe it's hard to reproduce even at my current version, because usually refresh works. But once - it hasn't. It was obvious missynchronization somewhere, so I decided to report it.


I'm not ready to update IDEA for latest version for a number of reasons as well. Anyway I've found workaround described in ticket and moved on.




Please sign in to leave a comment.