PHPStorm and Magento 2 laggy and slow

Been having issues with Magento 2 and PHPStorm for a while now. Using the latest 2018.1 release on Mac OS 10.13.4.

Often CPU usage would sky rocket and everything just comes to a halt. The only way I can really use it is in power saving mode but definitely not ideal.

Anyone else having similar issues or know of a way to resolve this?

See: https://cl.ly/041W2F1T0f2z/Image%202018-04-10%20at%2010.12.18.png

Thanks in advance :)

3 comments
Comment actions Permalink

Hi there,

Every performance issue can be machine specific .. and can be caused by other factors (e.g. old graphic drivers (especially for HiDPI screens) on High Sierra etc -- see this thread for some info: https://intellij-support.jetbrains.com/hc/en-us/community/posts/115000693290-Extreme-lag-and-high-CPU-usage-on-OSX-High-Sierra)

I would suggest to:

  1. Collect needed performance info (CPU snapshots / thread dumps) -- Reporting performance problems – IntelliJ Platform-based IDEs Support
  2. Use "Submit a Request" link at the top of the page to submit support ticket where you can attach your logs and other files privately.
0
Comment actions Permalink

I agree with Chris.  PHP Storm 2018.1 is now much slower than version 2018.  It's not clear why it happens, but while I am typing or moving my mouse, PHP Storm becomes sluggish or completely freezes for a while before it recovers.  The CPU usage does shoot up until it recovers.

0
Comment actions Permalink

I ended up increasing memory (Xmx) to 3072, invalidate caches / restart and turned off spell check. Seems to be more responsive now and havn't had an issue in the last few days.

0

Please sign in to leave a comment.