Mouse reverse scrolling

Answered

How to set the reverse scrolling on Intellij IDEA 20183.4? The touchpad is doing it correctly, but the mouse isn't.

I'm a Ubuntu 17.10 user and my mouse is set to reverse  (or "natural") scrolling. In some programs, eg. Firefox, it didn't work correctly but there was a solution through "about:config".

Is it possible to configure IntelliJ IDEA to use reverse scroll?

Thanks.

4 comments
Comment actions Permalink

Hi, there is no special settings, IntelliJ IDEA should inherit OS wide settings. Could you please clarify how exactly have you set Ubuntu for natural scrolling?

0
Comment actions Permalink

Hi, Petr. Sorry for the delay. Actually, it has been a while when I set the mouse wheel to "natural scrolling". The Ubuntu native programs work correctly, but IntelliJ doesn't. Your question imply that the method I used to configure the mouse could be not appropriate to IntelliJ, right? If yes, what's the method you recommend? I'll don't mind configuring my environment again. Thank you.

0
Comment actions Permalink

I updated Ubuntu from 17.10 to 18.04. The scroll now works fine.

Thx.

0
Comment actions Permalink

I have exactly the same problem. All applications from IDEA have reversed scrolling direction. I just used the natural scrolling in settings.

0

Please sign in to leave a comment.