Directories marked as test source root getting unmarked

Answered

Hi,

 

I'm working with a project that use composer and when I restart PhpStorm, the directories that I marked as a test source root get unmarked. How may I tell PhpStorm to stop unmarking my directories ?

 

Thanks for your help!

2 comments

Hi there,

Are they marked as such in composer.json?

Right now it sounds like IDE is syncing these settings (PHP Language Level + Source/Test roots) with composer.json (which happens on project opening) which overrides manually configured ones.

Either disable such syncing .. or define them in composer.json.

1

Hi Andriy,

I added the autoload-dev in my composer and it did marked the proper directories.

Thanks for your help!

0

Please sign in to leave a comment.