Intellij doesn't start anymore

Answered

After installing Eclipse; Intellij, PHPStorm and all Jetbrains Products i have installed on my Mac don't open anymore.
I already deleted all caches and logs but I wasn't able to start them yet.

It remains blocked on the loading screen. 

If anyone knows how to resolve this please tell me

0
32 comments

Yes. After deleting all IntelliJ directories from this location:

~/Library/Preferences/<PRODUCT><VERSION>

the product opened again.

 

0
  • Solution 100%

PLEASE SAVE YOUR PROJECTS BEFORE PROCEED INTO THIS JUST IN CASE

 

I tried literally for hours to make it work once stopped working for some reason! Here is my solution for you and it will work 100% . SAVE YOUR WORK before you do these steps please otherwise YOU WILL LOSE THEM . I checked everywhere on the internet and nobody gives a clear solution and especially not how to , the steps of how to. At least for me to make my life easier as i am new user of macbook.. Anyway here it is and please share it with others so you'll help other people too!

You need to completely remove IntelliJ from your computer because i saw i had double folders after the update of the program , not just delete it from the app screen and empty the trash and re download it and re install it because probably get the same issue! Here are the steps detailed for those are like me and for those are just stack and almost gave up trying!

1)  Go to the Applications folder → select the .app file (intelliJ) → make a right-click on it or two fingers tap to pop up options → select Move to Trash. Sometimes it may ask to enter your password and click OK to confirm the deletion. 

2) Then delete the service files of the IntelliJ application, which are stored in the Library. To do this,

open Finder → click Go in the menu bar from the top→ select Go to Folder from the drop-down menu. In the appeared window type

~/Library/

and click Go.  

3) Here, in the Library folder, find and remove-delete the subfolders that have to do with Intellij, which are related to the IntelliJ app. The name will be different depends the version you using. Look for the following subfolders:

~/Library/Application Support/IntelliJIdea2019  ( i had 2-3 folders there)

4) ~/Library/Caches/IntelliJIdea2019 (2 folders there)

5)~/Library/Preferences/IntelliJIdea2019 (3 folders there)

6)~/Library/Logs/IntelliJIdea2019 ( 2 folders there)

 

the duplication and three times folders made my program crash

 

7) Empty the Trash bin to complete the IntelliJ uninstallation.

download again a fresh intellij and install it and enjoy like before! Add your old work etc and everything is fine! 

I hope and i know i helped ! I wish everyone could take the time and help each other to save time and effort and frustration! Wanting to code and cant get your program work is crazy so i tried to find the best solution for me and the rest of you!

 

Enjoy 

Best regards

 

Angelo

 

0

Please sign in to leave a comment.