Intellij doesn't start anymore

Answered

After installing Eclipse; Intellij, PHPStorm and all Jetbrains Products i have installed on my Mac don't open anymore.
I already deleted all caches and logs but I wasn't able to start them yet.

It remains blocked on the loading screen. 

If anyone knows how to resolve this please tell me

0
32 comments

It seems to be a known issue that was fixed in 2018.1, that is why it works for you in EAP:

https://youtrack.jetbrains.com/issue/IDEA-184321
https://youtrack.jetbrains.com/issue/IDEA-182780

2

Could you please upload somewhere the complete content of the log folder zipped after issue happens?

>I already deleted all caches and logs but I wasn't able to start them yet.

To start with the default settings you also need to delete(move) config and plugins folders, please see https://intellij-support.jetbrains.com/hc/en-us/articles/206544519

1

Try re-download and bundle reinstall from https://www.jetbrains.com/idea/download or https://www.jetbrains.com/idea/nextversion If you have antivirus/firewall enabled exclude IDE installation bundle IDE settings from the scan.

Do you have internet access? Please provide content of `/etc/hosts` file.

Do you have any issues with the hard drive?

1

Thanks for the update. Try to deleting all other applications and install them into different directories. Or use ToolboxApp for managing all the IDEs on your computer.

1

I've already deleted the config and plugins folders, and to know where those files where i actually looked on the article you posted.
Now I restored the Mac from a backup I've done 3 days ago, where the Programms where working without any issue, but nothing Intellij, PhpStorm, Rider, ... won't start they block anyway. 
One more thing is that to start them I had to accept some terms and conditions, but it's strange because it wasn't the first time i started these programs. 
Anyway i upload the log files here: https://goo.gl/81Ju5M 
Thanks anyway for responding !

0

I installed the https://www.jetbrains.com/idea/nextversion and now it works.. but phpStorm and Rider, don't work anyway... I can't figure out why it is so... but for now I can also only use Intellij.. Thanks for help and to answer your questions:

I have internet access, the programs don't work with and don't work without internet connection, and no I don't have any hard drive issues.

and this is inside my /etc/hosts/ file:

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost
255.255.255.255 broadcasthost
::1 localhost

Firewall is deactivated and it's strange basically after accepting the new term and conditions they stopped working... Thank you once more for the tip to install the nextversion Intellij.

0

Okay I also had the idea trying to use toolbox thank you, I am going to try in a while

0

Know I tried to install everything using toolbox, before I deleted all logs, caches, application support, ... and it doesn't work anyway... but if I install the EAP version then everything works... could it be that the issue is connected with my Licenses or something like that? 

I really don't know what else I could do.. in order to let them start again..

 

UPDATE:
It doesn't depend on my account I tried to start the 30 days trial and it doesn't work anyway.
I will have to use the EAP for now I guess.

0

Oh if it's so thank you for the information.. To me it only seemed strange because it was working before and then not anymore... Anyway thank you for your support!

0

Just a guess for some things you could try:

- please check that the user under which you run IDEA has read/write access to "/Users/<User_name>/Library/Preferences/com.apple.java.util.prefs.plist" file and try to (temporarily) move file to some other location, and launch the IDE.

- add "idea.jre.check=false" in Help | Edit Custom Properties.

0

It looks like this command hangs on your system for some reason when it's executed by IntelliJ IDEA:

/Applications/IntelliJ\ IDEA.app/Contents/jdk/Contents/Home/jre/bin/java -version

Does it work in the Terminal or does it also hang? Please check it twice, while IntelliJ IDEA is running and when IDE is not running.

0

Well, I apologize but at the moment I'm not able to test it but also tried yesterday to start it from the terminal and it doesn't work anyway.

0

This test is to start Java VM to print its version in the Terminal, not to start IntelliJ IDEA.

0

Oh, I'm sorry I haven't looked exactly at it.. Anyway I will test it as soon as possible

0

I don't recieve any output.. I tried leaving this 'test' active also while I start Intellij but nothing it does not give an output.. Is that the issue?

0

Yes, it's the issue specific to your system. This command should return instantly and print the Java version. For some unknown reason it hangs on your system.

Are you able to get the thread dump of this java process using jstack?

0

Well I don't know exactly how to set up YouTrack.. but if on the next version it works anyway I can simply wait until the next version will be officially released or not?

Or should I reinstall Java?

0

I don't think reinstalling Java will help since it's the Java version that is bundled with IntelliJ IDEA.

See https://helpx.adobe.com/experience-manager/kb/TakeThreadDump.html and https://intellij-support.jetbrains.com/hc/articles/206544899 regarding getting the manual dumps using jstack. You need to get the dump of the `java -version` process that hangs.

0

Okay here i have the dump file of jps -mv command: https://drive.google.com/open?id=1n32QCzEvpVaQRX62_syXfP5PHpT3YUOS 
and here the specific dump using jstack: https://drive.google.com/open?id=1lyW1-cKl0Skm8TaCCv7-JQkodrWKqlHW 

I hope this will help

0

It's a dump of IntelliJ IDEA process, we need the dump of the JVM that is performing the `java -version` command.

You can get the PID via ps command, grep the process by the command line to find the ID of the one which performs the -version command. Or just close/terminate all the other Java processes so that it's easier to find.

0

That is a dump of jps process of Java 9. IntelliJ IDEA is bundled with Java 8.

0

I now have closed all other java processes in order to get the right one and if i try to jstack with the process ID it doesn't made it to get the error because the process ends after approximately 3 seconds with this output

0

Is there anything unusual on your system that can affect process execution? Antivirus monitor, some security setting, hardware issues? Does the issue persist if you create a new user account and start IntelliJ IDEA from it?

0

No my firewall isn't active, I don't have an antivirus and hardware issues well i don't think so it's a new Macbook Pro so I hope that it isn't that the point.. Now i try creating a new user ...

0

I tried with another user account.. IT WORKS! so it's not a hardware issue luckily.. But i still don't get to understand why it has this issue on my account

it was working fine and then suddenly not anymore..

0

Hard to say, some environment variable, a setting or permissions issue.

0

Okay anyway thank you for your support. I will try to figure out on my own.. I hope when 2018 version will be released it is going to work as it is now for the EAP.. Thank you a lot and have a good day!

0

Please sign in to leave a comment.