CocoaPods Support Broken?

Completed

Attempting to add cocoapods support to a new Obj-C project, I get a failure when attempting to update the list of available pods:

This means I can't create a podfile using AppCode.  I went with a new project, because I encountered the problem with a very old project I'm attempting to update and was pulling my hair out trying to figure out what was wrong. So I uninstalled AppCode, reinstalled and started from scratch with a new Single View App project and encountered the above error when attempting to update the repository to get a list of pods.

2 comments

I found the problem. I needed to run pod setup. No idea why this isn't included in the instructions for installing CocoaPods.

1

Hi Seamus.

>I needed to run pod setup

That shouldn't be the case, normally. Looks like at some point your pods installation (likely, quite old) got into the state which required additional actions (i.e. pod setup). I doubt it has anything to do with the IDE since we just use the CocoaPods based on selected version of Ruby SDK in Tools | CocoaPods.

0

Please sign in to leave a comment.