I'm having a huge problem with Webstorm and react-hot-loader.

I don't know if there's anything with the way Intellij auto-saves files, but this very procedure works in every other text editor.

I'm using React and a lib called react-hot-loader responsible for the hot reload of the project.

The problem happens when: let's says I have a parent component and a child component. When I edit the parent component, everything works fine. When I edit the child component, the hot reload doesn't work (even if I refresh the page it doesn't work) so I have to re-run the project.

This, or similar, happened with anyone?

4 comments
Comment actions Permalink

May be related to "safe write" feature that can potentially interfere with recompilation. Please try disabling Use "safe write" in Settings | Appearance & Behavior | System Settings - does it make things any better?

If this doesn't help, I'd suggest reporting the issue to react-hot-loader package vendor. see also https://github.com/gaearon/react-hot-loader/issues/511

1
Comment actions Permalink

The problem is with the Webstorm IDE. I increased the inotify size, if I remember well, and everything worked correctly.

0
Comment actions Permalink

I did disable the "safe write" in some past attempts but this doesn't solved the problem.

0
Comment actions Permalink

Hey, I just wanted to tell you, that I've tried with Settings > Appearance & behavior > Clic on System Settings , and then you find on your right side some option menus > Under the Synchronization menu, there is an option named "Use 'safe write' (save changes to a temporary file first)", make sur that, that option is unchecked > Restart webstorm and boom! the hot reloading will be back :D 

 

Good luck

0

Please sign in to leave a comment.