phpstorm 2018.1 log error: "Unable to save settings: Failed to save settings. Please restart PhpStorm"

Since i've installed Phpstorm via Toolbox i got this log error

I dont know of what "settings" it refers to. Except this log error everything else is working fine (projects, vcs and deployment settings are synced)

14 comments

This might be caused by some plugin. Please try to disable all custom plugins at File | Settings | Plugins > Show: Custom & check the issue after that.

0

I've got the same issue. Disabled every custom plugin, restarted PhpStorm and the error still pops up.

0

If you use Trello integration, there's https://youtrack.jetbrains.com/issue/IDEA-187507 -- fix will be available in the upcoming 2018.1.1.

0

Same error. It's triggered when I hit File > Save. I don't have Trello and all custom plugins disabled. I upgraded from the latest 2017, also tried doing a manual install. (OSX 10.13.3)

-- Update: The issue was the local idea directory in the project. I deleted this, and it fixed the issue. However, all my project settings are gone too, so not an ideal solution.

0

Same problem here:
The plugin com.intellij.tasks failed to save settings and has been disabled. Please restart PhpStorm.

Trigger when i accept a task server config.

I have disabled all costom plugins.

 

I have reinstalled PHPStorm, delete config files ..... no effect.

 

go to 2017.3.6 all ok

0

I had the same problem here. A new workspace.xml solved the problem, but many necessary settings were lost. Then I noticed, that "Open Task" did not work. At the settings for the tasks I got a never ending spinner.…

I deleted both servers, Mantis and GitLab and that fixed the error. Adding only mantis immediately caused the error, adding only GitLab works.

@ Dmitry:

Yes, it seems to be a problem with plugins, but not with custom ones but with a core plugin.

0

Romana, do I get right that it's still the case when you add a Mantis task server to the configuration?

0

Yes, as soon as I add a mantis server, I get this error

0

In my case I've opened phpStorm without enough permissions to write into project folder, when I added to properties of shortcut for running the phpStorm as Administrator this error message are disappear

0

This issue still occurred in 2018.2 even though I opened PHPStorm with admin rights.

0

This issue still occurred in 2018.2 even though I opened PHPStorm with admin rights.

It's not the same issue each time, it's the same symptom pointing to different problems. We need to take a look at your log after you got the issue, please collect IDE log and upload it somewhere.

0

Seems this error comes from a failed swap on temporary file.

Inside of your project check the folder .idea

Delete the temporary file like:

 

workspace.xml___jb_old___

 

Or something like it, you need have only one:

 

workspace.xml

 

About delete the file, check too if they have same size and contents, in my situation both are same contents and size...

 

Ps.: I got this error too on:

PhpStorm 2018.3.3
Build #PS-183.5153.36, built on January 9, 2019
JRE: 1.8.0_152-release-1343-b26 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0

0

Disabling the "Markdown Support" plugin fixed it for me.

1

On Windows 10, Webstorm 2018.3.5, giving "Full control" rights to "Everyone" on that ".idea" folder and removing "Read Only" status worked for me.

0

Please sign in to leave a comment.