Goland Debugger : could not launch process: EOF


I have the following setup:

MacOS High Sierra 10.13.4 (17E199)

go version go1.9.3 darwin/amd64

Goland 2017.3

I cannot start the debugger in Goland anymore. It just stopped working at some point. I get this in the console:

could not launch process: EOF

Debugger finished with exit code 1

I tried reinstalling go, upgrading to goland 2018.1, reinstalling goland 2017.3. No luck.

Any clue what I could do to troubleshoot this?

Thanks in advance,


Official comment

Delve doesn't work with the new MacOS command line tools. See related issues https://youtrack.jetbrains.com/issue/GO-5527 and https://github.com/derekparker/delve/issues/1165.

Workaround is on the way, stay tuned.

Have the same issue

could not launch process: EOF
Debugger finished with exit code 1


In my case I use IntelliJ 

IntelliJ IDEA 2018.1 (Ultimate Edition)
Build #IU-181.4203.550, built on March 26, 2018
Licensed to XXXXX
Subscription is active until July 10, 2018
JRE: 1.8.0_152-release-1136-b20 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.4

And go 1.10.1

Version: 181.4203.564.171


This is tracked as an issue here: https://youtrack.jetbrains.com/issue/GO-5527 

Please try the following workaround: https://github.com/derekparker/delve/issues/1165#issuecomment-377676853  and see if it works for you.


Worked for me: https://github.com/derekparker/delve/issues/1015 (download old version of Apple Developer tools - bug was introduced 1/April)




I updated Mac command line tool, then follow this https://stackoverflow.com/a/43014980/2048865

And thing works.


Please sign in to leave a comment.