docker-compose does not work on ubuntu using default settings

I have set up docker-compose as a remote interpreter.

I have followed the instructions here: https://www.jetbrains.com/help/pycharm/using-docker-compose-as-a-remote-interpreter-1.html

I deviated from those instructions by using the "unix socket" radial rather than the TCP radial. TCP did not work (connection refused), and unix socket was default anyway.

I get the following error:

Traceback (most recent call last):
File "bin/docker-compose", line 6, in <module>
File "compose/cli/main.py", line 71, in main
File "compose/cli/main.py", line 124, in perform_command
File "compose/cli/command.py", line 38, in project_from_options
File "compose/cli/docker_client.py", line 84, in tls_config_from_options
File "site-packages/docker/tls.py", line 81, in __init__
docker.errors.TLSParameterError: Path to a certificate and key files must be provided through the client_config param. TLS configurations should map the Docker CLI client configurations. See https://docs.docker.com/engine/articles/https/ for API details.
[8472] Failed to execute script docker-compose

I have tried multiple projects. All get the same result. This is a pretty clean ubuntu install containing only docker, compose, git, pycharm, and my project.

I also created a SO post here: https://stackoverflow.com/questions/49595809/docker-compose-integration-not-working-in-pycharm

Using pycharm pro 2018.1

4 comments
Comment actions Permalink

I had the same problem in Rubymine. This SO thread solved it for me:

- Go to Settings >> Build, Execution, Deployment >> Docker

- Select "TCP socket"

- Enter 'unix:///var/run/docker.sock' under "Engine API URL"

 

After that, try to set up docker-compose as remote interpreter again...

10
Comment actions Permalink

Thank you very much! This works like a charme.

1
Comment actions Permalink

Thanks, Daniel! This worked on Idea Community on Fedora.

0

Please sign in to leave a comment.