docker-compose does not work on ubuntu using default settings


I have set up docker-compose as a remote interpreter.

I have followed the instructions here:

I deviated from those instructions by using the "unix socket" radial rather than the TCP radial. TCP did not work (connection refused), and unix socket was default anyway.

I get the following error:

Traceback (most recent call last):
File "bin/docker-compose", line 6, in <module>
File "compose/cli/", line 71, in main
File "compose/cli/", line 124, in perform_command
File "compose/cli/", line 38, in project_from_options
File "compose/cli/", line 84, in tls_config_from_options
File "site-packages/docker/", line 81, in __init__
docker.errors.TLSParameterError: Path to a certificate and key files must be provided through the client_config param. TLS configurations should map the Docker CLI client configurations. See for API details.
[8472] Failed to execute script docker-compose

I have tried multiple projects. All get the same result. This is a pretty clean ubuntu install containing only docker, compose, git, pycharm, and my project.

I also created a SO post here:

Using pycharm pro 2018.1


I had the same problem in Rubymine. This SO thread solved it for me:

- Go to Settings >> Build, Execution, Deployment >> Docker

- Select "TCP socket"

- Enter 'unix:///var/run/docker.sock' under "Engine API URL"


After that, try to set up docker-compose as remote interpreter again...


Thank you very much! This works like a charme.


Thanks, Daniel! This worked on Idea Community on Fedora.


Thanks Daniel! It works for me on PyCharm


Thanks, Daniel! This works for WebStorm 2020.2 on Ubutnu 20.04.1.


Top Daniel, that works.


Thanks, Daniel! 
This works for PhpStorm on Ubuntu 20.04.02!


Please sign in to leave a comment.