[BUG] Keyboard gets locked or inactive on IntelliJ IDEA on MacOS


I have faced this issue twice this week. (no vim plugin installed).

The keyboard suddenly stops working (both external and macbook pro). The mouse stays active and I can copy, paste, mark code and move it etc..

I have never noticed any circumstance that could lead to this but it was very annoying because I had to restart IntelliJ.

IntelliJ IDEA 2018.1.5 (Ultimate Edition)
Build #IU-181.5281.24, built on June 12, 2018
JRE: 1.8.0_152-release-1136-b39 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.5

Macbook Pro i7 3,5GHz, 16GB Ram 

Arseniy Nisnevich


Please, try the latest version of IntelliJ IDEA: https://www.jetbrains.com/idea/download

And check if the workaround from the comment above helps: https://intellij-support.jetbrains.com/hc/en-us/community/posts/360000175420/comments/360000430339



I'm facing similar problem.

What I have noticed is that in some editor windows only backspace is blocked on other backspace and enter doesn't work.

I have tried "defaults write -g ApplePressAndHoldEnabled -bool false" without success. Latest 2019.2.2 RC doesn't fix it too.

Backspace stops working as soon as indexing is finished.


PhpStorm 2019.2.1 (MacOS Mojave - 10.14.6)
Build #PS-192.6262.66, built on August 22, 2019

Runtime version: 11.0.3+12-b304.39 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.6
GC: ParNew, ConcurrentMarkSweep
Memory: 1740M
Cores: 8
Registry: run.processes.with.pty=TRUE, ide.usages.page.size=10000, debugger.watches.in.variables=false
Non-Bundled Plugins: Quick Notes, String Manipulation, com.intellij.ideolog, com.intellij.jira, mobi.hsz.idea.gitignore, net.seesharpsoft.intellij.plugins.csv, de.espend.idea.laravel, de.espend.idea.php.annotation, fr.adrienbrault.idea.symfony2plugin, ru.adelf.idea.dotenv




I've found that it was problem with code in the file (or actually bug in PhpStorm)

OK let's see. Host file: BLADE_FILE in '/resources/views/public/member-partner/login.blade.php' (Language: Blade) 
Was injected Language: AngularJS at ranges: [Shred in XmlText with range (34,85) (class com.intellij.psi.impl.source.xml.XmlTextImpl) inside range (9,18)]
java.lang.RuntimeException: After patch: doc:
OK let's see. Host file: BLADE_FILE in '/resources/views/public/member-partner/login.blade.php' (Language: Blade)
Was injected Language: AngularJS at ranges: [Shred in XmlText with range (34,85) (class com.intellij.psi.impl.source.xml.XmlTextImpl) inside range (9,18)]
at com.intellij.psi.impl.source.tree.injected.InjectionRegistrarImpl.parseFile(InjectionRegistrarImpl.java:686)
at com.intellij.psi.impl.source.tree.injected.InjectionRegistrarImpl.createAndRegisterInjected(InjectionRegistrarImpl.java:270)
at com.intellij.psi.impl.source.tree.injected.InjectionRegistrarImpl.doneInjecting(InjectionRegistrarImpl.java:235)
at com.intellij.lang.javascript.JSInjectionBracesUtil.injectInXmlTextByDelimiters(JSInjectionBracesUtil.java:155)
at com.intellij.lang.javascript.JSInjectionBracesUtil.injectInXmlTextByDelimiters(JSInjectionBracesUtil.java:116)
at org.angularjs.editor.AngularJSInjector.getLanguagesToInject(AngularJSInjector.java:73)
at com.intellij.psi.impl.source.tree.injected.InjectedLanguageManagerImpl.processInPlaceInjectorsFor(InjectedLanguageManagerImpl.java:421)
at com.intellij.psi.impl.source.tree.injected.InjectedLanguageUtil.probeElementsUp(InjectedLanguageUtil.java:348)
at com.intellij.psi.impl.source.tree.injected.InjectedLanguageUtil.enumerate(InjectedLanguageUtil.java:173)
at com.intellij.psi.impl.source.tree.injected.InjectedLanguageManagerImpl.enumerateEx(InjectedLanguageManagerImpl.java:315)
at com.intellij.codeInsight.daemon.impl.LineMarkersPass.queryLineMarkersForInjected(LineMarkersPass.java:223)
at com.intellij.codeInsight.daemon.impl.LineMarkersPass.queryProviders(LineMarkersPass.java:185)
at com.intellij.codeInsight.daemon.impl.LineMarkersPass.lambda$doCollectInformation$3(LineMarkersPass.java:96)
at com.intellij.codeInsight.daemon.impl.Divider.divideInsideAndOutsideInOneRoot(Divider.java:79)
at com.intellij.codeInsight.daemon.impl.LineMarkersPass.doCollectInformation(LineMarkersPass.java:91)
at com.intellij.codeHighlighting.TextEditorHighlightingPass.collectInformation(TextEditorHighlightingPass.java:55)
at com.intellij.codeInsight.daemon.impl.PassExecutorService$ScheduledPass.lambda$null$1(PassExecutorService.java:429)
at com.intellij.openapi.application.impl.ApplicationImpl.tryRunReadAction(ApplicationImpl.java:1106)
at com.intellij.codeInsight.daemon.impl.PassExecutorService$ScheduledPass.lambda$doRun$2(PassExecutorService.java:422)
at com.intellij.openapi.progress.impl.CoreProgressManager.registerIndicatorAndRun(CoreProgressManager.java:591)
at com.intellij.openapi.progress.impl.CoreProgressManager.executeProcessUnderProgress(CoreProgressManager.java:537)
at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:59)
at com.intellij.codeInsight.daemon.impl.PassExecutorService$ScheduledPass.doRun(PassExecutorService.java:421)
at com.intellij.codeInsight.daemon.impl.PassExecutorService$ScheduledPass.lambda$run$0(PassExecutorService.java:397)
at com.intellij.openapi.application.impl.ReadMostlyRWLock.executeByImpatientReader(ReadMostlyRWLock.java:164)
at com.intellij.openapi.application.impl.ApplicationImpl.executeByImpatientReader(ApplicationImpl.java:204)
at com.intellij.codeInsight.daemon.impl.PassExecutorService$ScheduledPass.run(PassExecutorService.java:395)
at com.intellij.concurrency.JobLauncherImpl$VoidForkJoinTask$1.exec(JobLauncherImpl.java:161)
at java.base/java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:290)
at java.base/java.util.concurrent.ForkJoinPool$WorkQueue.topLevelExec(ForkJoinPool.java:1020)
at java.base/java.util.concurrent.ForkJoinPool.scan(ForkJoinPool.java:1656)
at java.base/java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1594)
at java.base/java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:177)
2019-09-09 10:15:00,808 [1481427] ERROR - n.impl.GeneralHighlightingPass - Last Action: EditorBackSpace
2019-09-09 10:15:00,808 [1481427] ERROR - aemon.impl.PassExecutorService - PhpStorm 2019.2.2 RC Build #PS-192.6603.26
2019-09-09 10:15:00,808 [1481427] ERROR - aemon.impl.PassExecutorService - JDK: 11.0.3; VM: OpenJDK 64-Bit Server VM; Vendor: JetBrains s.r.o
2019-09-09 10:15:00,808 [1481427] ERROR - aemon.impl.PassExecutorService - OS: Mac OS X
2019-09-09 10:15:00,808 [1481427] ERROR - aemon.impl.PassExecutorService - Last Action: EditorBackSpace


> I've found that it was problem with code in the file

Do you mean that the problem is repeatable in only a single specific file for you?


Even after restarts, and closing down all projects I still could not interact with the mouse.

Doing `defaults write -g ApplePressAndHoldEnabled -bool false` in the terminal and logging out and back in resolved the issue, like mentioned above. Also tried the EAP build (2019.3) but did not solve the issue.


This problem happen to me with the last version :(.


Same issue with two projects open my typing is going into a terminal tab of the project in the background. When I close the terminal tabs of the other project windows the typing works.

IntelliJ IDEA 2019.2.3 (Ultimate Edition)
Build #IU-192.6817.14, built on September 23, 2019

Runtime version: 11.0.4+10-b304.69 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.5
GC: ParNew, ConcurrentMarkSweep
Memory: 1979M
Cores: 16
Non-Bundled Plugins: com.tang, in.xiv.cs, BashSupport


This bug happened twice for me today already, using latest Rider + Linux.

Arseniy Nisnevich


The problem that you've described looks like https://youtrack.jetbrains.com/issue/JBR-1573

Could you please try the workaround from the description of the issue?


Very annoying... Long Press 'p' worked for me. 

Build #PS-182.4323.68, built on September 13, 2018
JRE: 1.8.0_152-release-1248-b8 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.6


Is it possible to try our latest EAP version and check this bug there?


Happened to me a few times. Noticed that it started to happen when I open multiple instances of Idea. Long press 'p' worked.


Happens to me almost every time I open several projects in different windows. Cursor is stuck in one of the terminals, I can't type anything in IDE whatsoever. Extremely frustrating. It didn't happen on 2019.2 & 2019.1. Happens with all IDEs I use (goland, webstorm, php storm, pycharm). 


I use leap 15.1 with openjdk.


What is leap 15.1? Why don't you use JetBrains Runtime? See https://intellij-support.jetbrains.com/hc/articles/206544879 .


The same problem with Goland 2019.3.4


This is happening reliably when using the mouse/keyboard sharing application "Synergy"(https://symless.com/synergy) and macos.
It is reproducible under idea versions 2019.3 and 2020.1

Double Command-Tab restores the cursor, but it's really annoying.



We have bug regarding mouse cursor and Synergy: 


Please check if it fits your case and submit a new request if it does not. 


Ah yeah, that bug seems to match up with the behavior I see.


Feel free to watch it in order to be notified once it has updates. See this article if you are not familiar with YouTrack.


In my case the issue usually presents when tabbing between instances of IntelliJ (ALT+`) or files within IntelliJ (CTRL+TAB).  I'm using the GNOME key map.

This only started happening after upgrading to Ubuntu 20.04 LTS.  I was using IntelliJ Ultimate (idea-IU-193.6911.18).  I tried upgrading to the latest version (idea-IU-201.7223.91), but it hasn't resolved the issue.


@Yaroslav Bedrov Thank you !
This worked perfectly for me on ubuntu 20.04


I had same problem in intelij 2020.1 . sometime keyboard doesn't support but mouse work smoothly..

Arseniy Nisnevich

Hi Ranjandhakal664,

Please see "Workaround" section of this issue.


This just happened to me on Mac. Seems resolved by using option+cmd+` to switch between editors. 


Please sign in to leave a comment.