WebStorm 2018.1 Mac Version does not run single Unit Tests with Jest

I do not know what happened but I can't run single Unit Test, the process stuck in Instantiating tests

But if I execute that command in the terminal everything goes well

And if I run all the test there is no problem


Not enough info to see what's wrong... try changing the working directory in your single test run configuration to the one where your package.json resides - does it help?


I had the same problem, and Elena's suggestion fixed the issue. I added the working directory that contains my package.json to my default Jest test configuration, and it's been running smoothly since then.

It seems like a bug, maybe something can be done about that?


It didn't work for me, but I solved in a really weird way, I debugged the test and I notice that was stuck in this function in the package require_optional, so that's the reason why the the process stuck in Instantiating tests

So I added find_package_json.caller() and everything worked again


Please sign in to leave a comment.