Python 3.7 won't install in Pycharm 2018.1.4 (windows 10)

Completed

I suspect it is trying to use 3.6 to do some of the install, as seen below, maybe there is a bad path somewhere?

C:\PyCharm 2018.1.3\helpers\packaging_tool.py pyvenv C:\Users\freemti\venv\test37

Traceback (most recent call last):
File "C:\PyCharm 2018.1.3\helpers\packaging_tool.py", line 2, in <module>
import traceback
File "C:\Python36\Lib\traceback.py", line 5, in <module>
import linecache
File "C:\Python36\Lib\linecache.py", line 11, in <module>
import tokenize
File "C:\Python36\Lib\tokenize.py", line 33, in <module>
import re
File "C:\Python36\Lib\re.py", line 123, in <module>
import sre_compile
File "C:\Python36\Lib\sre_compile.py", line 17, in <module>
assert _sre.MAGIC == MAGIC, "SRE module mismatch"
AssertionError: SRE module mismatch

2 comments

I also tried installing as non virtual (venv) same error

0

I fixed this (with some assistance from Jetbrains) - it was a collision with my existing 3.6 install, I removed PYTHONPATH environmental variable I had set and everything worked fine. 

0

Please sign in to leave a comment.