'Import module from Gradle' - how to get to this window?

Answered

Hello,

I open a Gradle project with 'File -> Open'. A pop-up 'Unlinked Gradle project?' appears and goes away. This pop-up has a link that opens the 'Import module from Gradle' window. The pop-up has gone and I want to get to that window otherwise nothing gets resolved.

How do I get to the 'Import module from Gradle' window now?

 

3
11 comments

This does not answer my question. The guide says click on the link, whereas I say the link's gone. The guide says nothing about what to do once the link has disappeared, it only assumes the happy path.

So how do I enable the Gradle Projects tool window when I'm too slow at this chase-the-link game? Are you suggesting that if I miss this opportunity there is no way other than to try again or go the import route? I can see a usability problem here. Why not make this a permanent option somewhere, say, in one of the file menus?

3

Hi. Does it helps if you open and close a project? Also please upvote https://youtrack.jetbrains.com/issue/IDEA-162677

0

Right, so it's a bug, that's what I wanted to know. Thanks.

I've already learnt of the workarounds or "right" ways to open Gradle projects but the thing is there will be period of time when I don't work with Idea managed Gradle projects for a while, then come back, simply open a project directory with 'File -> Open' and scratch my head again why Idea doesn't recognise the project.

I don't really understand why Idea is asking this question in a pop-up at all since the project is unusable if you don't "link" it. I think this is the same when it comes to VCS - you have to explicitly link your project. I haven't seen anything like this in other IDEs, there you just open a project and everything is "linked" (try, for example, Netbeans).

At the very least the pop-up should not disappear since I may be dealing with other things (maybe even on another OS workspace) while the project is loading and not notice it. Ideally it shouldn't be required to explicitly "link" the project.

3

Hello. The ticket I have provided is not a bug, it is a feature request to make gradle project linking easier. The case you have described (Gradle project getting linked by itself), on the other hand, looks like a bug. Are you sure you are opening existing IDEA project (that have .idea folder) using File | Open?

0

This does not answer my question. The guide says click on the link, whereas I say the link's gone. The guide says nothing about what to do once the link has disappeared, it only assumes the happy path.

So how do I enable the Gradle Projects tool window when I'm too slow at this chase-the-link game? Are you suggesting that if I miss this opportunity there is no way other than to try again or go the import route? I can see a usability problem here. Why not make this a permanent option somewhere, say, in one of the file menus?

-------
Now, I have encountered this situation. the link's gone!!Never show again! How can I do ???  I can't open the window :

Import module from Gradle

it's a bug?

0

Can I only re-import the project?  I accidentally clicked 'detach gradle project',and then I I missed the guide link,the link never show again ....How can I do???

卧槽!

1

卧槽!卧槽!卧槽!

0

@Pc949956906


Please import the project back by selecting "build.gradle" file in the Project window and use "Import Gradle project" action in the context menu: 

https://i.imgur.com/kdzkcDz.png

Here is the additional documentation regarding that: 

https://www.jetbrains.com/help/idea/work-with-gradle-projects.html#Work_with_Gradle_projects.xml 

0

首先,谢谢你哦。

I have re-imported the project yesterday,and now the project is normal .

I still can't find the imported button that you said, maybe my version is lower. . .

Thanks for your answer...

0

@Pc949956906

You are right. That button has been added recently. 

So, please update your IntelliJ IDEA to the last version. 

0

Please sign in to leave a comment.