Find usages... - GoLand 2018.1.1

Hi everyone,

I just downloaded a fresh copy of GoLand of the website. After browsing a project for a bit, I noticed that the "Find usages" only scopes to the current package. 

I modified and tried several scopes, including "All Places" in the "Find Usage" settings : same result. Even though I'm not exactly sure what it does I tried "Invalidate caches / restart" and also "synchronize". None of them worked.

I'm not aware of anything else I can test. 

It's a very recent version : GoLand 2018.1.1 - Build #GO-181.4445.70 (April 9, 2018).

JRE: 1.8.0_152-release-1136-b27 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.3






1 comment
Official comment

GoLand uses a real usage scope of declaration while looking for usages. E.g. package-scope for non-exported variables, block scope for local variables, etc.

If you think it works incorrectly in some cases, provide the code samples and steps to recreate the problem, please.

Please sign in to leave a comment.