Loading components when Loading a project for a long time(2min+)

Answered

show "loading components" for a long time when loading a project.
the log show it like this:
2018-04-17 23:37:40,624 [ 20352] INFO - .openapi.application.Preloader - Finished preloading com.intellij.ide.actions.GotoClassPresentationUpdater@908ddd9
2018-04-17 23:39:39,193 [ 138921] INFO - ellij.project.impl.ProjectImpl - 159 project components initialized in 123502 ms

 

IDEA: 2018.1.1

27 comments
Comment actions Permalink

Our team is having the same issue. Project loading hangs up for 5 or even more minutes on this progress bar. It loads after all but it really sucks to wait... we usually have to restart the Application.

0
Comment actions Permalink

Please provide the thread dumps via jstack, see https://intellij-support.jetbrains.com/hc/articles/206544899. Also provide the logs: Help | Compress Logs and Show in ...

Report the issue at https://youtrack.jetbrains.com/issues/IDEA with all the files attached.

0
Comment actions Permalink

I see there is an issue of such case already.
https://youtrack.jetbrains.com/issue/WI-48214

Even more I see such case appeared on IntelliJ IDEA board ( https://youtrack.jetbrains.com/issue/IDEA-220475 ) and is fixed with latest 2019.3 release. Hope same will be fixed with new PhpStorm.

0
Comment actions Permalink

In my case, removing venv directory solved the problem

0
Comment actions Permalink

Seems in some cases those 'components' need to do something via the network. I forgot to log in my VPN and was stuck loading for multiple minutes (usually it's 3 seconds or smth). Restored connectivity, got past it.

0
Comment actions Permalink

I am stuck on that screen too. Meanwhile in the terminal (started IntelliJ from command line) I can see:

2020-03-30 05:25:46,904 [ 11704] WARN - reporter.KotlinReportSubmitter - connect timed out 
java.net.SocketTimeoutException: connect timed out
at java.base/java.net.PlainSocketImpl.socketConnect(Native Method)
at java.base/java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:399)
at java.base/java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:242)
at java.base/java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:224)
at java.base/java.net.SocksSocketImpl.connect(SocksSocketImpl.java:403)
at java.base/java.net.Socket.connect(Socket.java:609)
at java.base/sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:285)
at java.base/sun.net.NetworkClient.doConnect(NetworkClient.java:177)
at java.base/sun.net.www.http.HttpClient.openServer(HttpClient.java:474)
at java.base/sun.net.www.http.HttpClient.openServer(HttpClient.java:569)
at java.base/sun.net.www.protocol.https.HttpsClient.<init>(HttpsClient.java:265)
at java.base/sun.net.www.protocol.https.HttpsClient.New(HttpsClient.java:372)
at java.base/sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(AbstractDelegateHttpsURLConnection.java:191)
at java.base/sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1227)
at java.base/sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:1081)
at java.base/sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:177)
at java.base/sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1587)
at java.base/sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1515)
at java.base/java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:527)
at java.base/sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(HttpsURLConnectionImpl.java:334)
at com.intellij.util.io.HttpRequests.openConnection(HttpRequests.java:607)
at com.intellij.util.io.HttpRequests.access$300(HttpRequests.java:56)
at com.intellij.util.io.HttpRequests$RequestImpl.getConnection(HttpRequests.java:376)
at com.intellij.util.io.HttpRequests$RequestImpl.getInputStream(HttpRequests.java:385)
at org.jetbrains.kotlin.idea.KotlinPluginUpdater$Companion$fetchPluginReleaseDate$pluginDTOs$1.process(KotlinPluginUpdater.kt:348)
at org.jetbrains.kotlin.idea.KotlinPluginUpdater$Companion$fetchPluginReleaseDate$pluginDTOs$1.process(KotlinPluginUpdater.kt:320)
at com.intellij.util.io.HttpRequests.doProcess(HttpRequests.java:518)
at com.intellij.util.io.HttpRequests.process(HttpRequests.java:500)
at com.intellij.util.io.HttpRequests.access$100(HttpRequests.java:56)
at com.intellij.util.io.HttpRequests$RequestBuilderImpl.connect(HttpRequests.java:350)
at org.jetbrains.kotlin.idea.KotlinPluginUpdater$Companion.fetchPluginReleaseDate(KotlinPluginUpdater.kt:347)
at org.jetbrains.kotlin.idea.reporter.KotlinReportSubmitter$Companion$setupReportingFromRelease$1.run(KotlinReportSubmitter.kt:93)
at com.intellij.openapi.application.impl.ApplicationImpl$1.run(ApplicationImpl.java:238)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:834)

...which is interesting because I have "Send usage statistics" turned off. I am behind a proxy, but environment variables are set.

I am using 2019.3 (aka. 193.6911.18).

Deleting the .idea folder helps, but only for one restart, the next time (when .idea is re-generated) the UI get stuck on the same point. I can see the exception even on the successful run (after deleting .idea).

Thanks

0
Comment actions Permalink

The exception means that the IDE fails to check for updates of a Kotlin plugin b/c the connection to server times out. It is not related to usage statistics.

Please share the thread dumps via jstack: https://intellij-support.jetbrains.com/hc/articles/206544899 when it hangs.

0
Comment actions Permalink

Please, fix this issue. Every time when I open the second project it hangs on the Loading Components. If I load one project, then everything loads quickly.

0
Comment actions Permalink

Shaposhnyk There might be different reasons that cause this problem. Can you please raise a new issue at https://youtrack.jetbrains.com/issues/IDEA, and capture a thread dump via jstack to check your case? (https://intellij-support.jetbrains.com/hc/en-us/articles/206544899)

0
Comment actions Permalink

Egor Klepikov I don't understand that instruction which you sent to me. please get me an easy decision on my issue. fixed that troubles, please. Thank you.

0
Comment actions Permalink

We would like to help you, but without diagnostic data, it is hard to say why you encountered this problem. Here is a short instruction on how to collect the needed information:

  • Disable all third-party plug-ins.
  • Quit the IDE.
  • Launch the IDE and reproduce the problem.
  • Find the PID of IntelliJ IDEA process via jps or system task manager.
  • Open the system command line and execute jstack -l <PID> > dump.txt . (JAVA_HOME must be configured)
  • Collect diagnostic data. (Help | Collect Logs and Diagnostic Data)
  • Raise a new issue at https://youtrack.jetbrains.com/issues/IDEA, and attach the command line output and collected diagnostic data.

This way we can analyze how the internal subsystems work when the problem occurred.

Also, try using the latest version from https://www.jetbrains.com/idea/download/#section=windows .

0
Comment actions Permalink

Thank you.

But I didn't find any "IntelliJ" process on my mac. 

jstack isn't found too.

#jstack

No Java runtime present, requesting install

I would like to repeat it again. if I run one project, everything loads quickly, but when I load several projects, phpstorm is not responding to "Loading modules"... but it does not always do it .

thank you.

0
Comment actions Permalink

> I would like to repeat it again. if I run one project, everything loads quickly, but when I load several projects, phpstorm is not responding to "Loading modules"... but it does not always do it .

Probably it is related to https://youtrack.jetbrains.com/issue/IDEA-250779 . Please try using the 2020.3 EAP build from https://www.jetbrains.com/phpstorm/nextversion .

0
Comment actions Permalink

2020.3 EAP Worked for me! Thanks

1
Comment actions Permalink

I've the same Problem:

Start PHPStorm, load 1st project from mounted NFS volume...works (every time), open a 2nd project from NFS volume:

then shows "Loading components"...for ever!!!

Version: PHPStorm 2020.3.2 (2020-01-27)

Any further solutions?

 
0
Comment actions Permalink

Bellebrecht

Please attach the following information to the IDEA-250779's comment thread:

  • Several jstack thread dumps of the IDE process taken with the Help | Diagnostic Tools | Dump Threads action, or dumped manually from the console as described here.
  • The entire log folder (Help | Collect Logs and Diagnostic Data).
  • java_error_in_idea.hprof files (if any) found in your user home directory. You can upload them to https://uploads.jetbrains.com/ and provide the upload id.

See this article if you are not familiar with YouTrack.

0
Comment actions Permalink

This issue occurred to me today while opening/closing multiple projects in rapid succession.  Attached are 2 jstacks taken while the IDE was stuck on "Loading Components..."

Upload id: 2021_03_30_57i6znFFWvBNexHH (files: loadingcomponents.jstack, loadingcomponents2.jstack)


0
Comment actions Permalink

This seems to happen when rapidly closing / opening between 2 very large projects.  Is the IDE perhaps blocking on a VFS/indexing operation from the open-project actions of the previous project?  I could not reproduce this for smaller projects.

0
Comment actions Permalink

Same issue here. My problem were soft links in the project structure to large amounts of data.

What SOLVED it for me was to create a new empty project, change the project path in the settings and exclude the folder that contains the soft links to the data:

Make a new empty project that loads
File -> Settings (or Ctrl + Alt + S)
Project Structure
Add Content Root (add path to real project here and delete path to empty dummy project)
Exclude folder with links to large data sets, so that these folders are in the excluded Folders sections (right click and exclude)
Apply
close PyCharm, reopen: loads fast

It would be nice, if you could specify folders to exclude directly before opening a project and not by this backwards through the chest method

0
Comment actions Permalink

I have tried so many results and 'fixes' I've found but none of these seems to work, my IntelliJ IDEA stops being responsive after two clicks on any where be it the frames of that window...it takes long to load the projects with no final change, it's like frozen, can't close the window, can't do anything, I have to close the software through the windows task manager but it's like loading in background because it is prompting me of the new update but is not clickable. Any leads, almost the forth day. May I consider downloading the IDE again from the website???

0
Comment actions Permalink

the problem still remains ... from time to time it just hangs the whole system, and all the windows of phpstorm with opened projects... please fix it... It works properly just only one time when I begin to open firstly the project which hanged previously.

0
Comment actions Permalink

I have the same issue too... Egor Klepikov with the lastest version. OS Ubuntu 20.

When I open a second window it is hanging on Loading components FOREVER. 

1
Comment actions Permalink

I'm so sad.  Everytime I have updated Intellij in the last 2-3 years, I have only been met with more problems.  No improvements.

Why am I hurting myself like this?

Fix this problem ASAP.  It is a SHOW STOPPER.

0
Comment actions Permalink

Artnaseef Please report at https://youtrack.jetbrains.com/newIssue?project=IDEA with the CPU snapshot attached: https://intellij-support.jetbrains.com/hc/en-us/articles/207241235. Also provide the logs via Help | Collect Logs and Diagnostic Data.

0

Please sign in to leave a comment.