Closing tag matches nothing on </body> </html>

I have a file called footer.php and it has a closing body and html tag. is there a way to get phpstorm to ignore them? 

its funny that the header.php doesnt have messages that the <body> and <html> tags are opened by not closed.

3 comments
Comment actions Permalink

I don't think there is an option for that except disabling the warnings on certain scope level.
but if you are using HTML5 you can omit the body and html closing tag all together..

0
Comment actions Permalink

I was not able to find a preference to uncheck this warning. I only  see missing or redundant in the prefs. I'm doing some WordPress work, is there a way to make a template aware of the included files?

0
Comment actions Permalink

Unfortunately, no, there's no such way at the moment.
Please vote: https://youtrack.jetbrains.com/issue/WEB-32239

0

Please sign in to leave a comment.