"development cannot be enabled while your device is locked" message appearing

Answered

I installed the latest AppCode-EAP (Build #OC-182.3684.8) and now I am constantly getting a popup message in the bottom right saying 

--------

_the name of my phone_

Development cannot be enabled while your device is locked.

Please unlock your device and reattach.

--------

I haven't been doing any mobile dev at all.  

 

The message pops up every 3 minutes or so.

7 comments
Official comment

Hi Saro,

>I haven't been doing any mobile dev at all.

Could you specify whether iOS device is connected to mac wirelessly or via cord?

I experience the same issue. The device is nor connected to my Mac wirelessly nor via cable.

I'm using:

AppCode 2018.2.1
Build #OC-182.3911.53, built on August 14, 2018
JRE: 1.8.0_152-release-1248-b8 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.6

0

Please try out 2018.2.2 EAP build 182.4323.4 and let us know if it helps.

 

0

Done. But it doesn't help:

 

AppCode 2018.2.2 EAP
Build #OC-182.4323.4, built on August 21, 2018
JRE: 1.8.0_152-release-1248-b8 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.6

0

I'm having the same issue with AppCode. Is there a way to tell AppCode to not look for devices?

AppCode 2018.2.2
Build #OC-182.4323.25, built on August 29, 2018
JRE: 1.8.0_152-release-1248-b8 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.6

0

@Florian, @Jonathan,

Guys, I've created OC-17736 based on your reports. I've happened to see the issue myself some time before but cannot reproduce it at the moment. So, any additional info that you could share would be helpful.

Please specify (in comment for OC-17736): 

- which iOS version the device is running?

- have you ever switched "Connect via network" option on for that device (maybe, someone else on another workstation could have done that?)

Also please try the following:

1) dismiss/clear all the "development cannot be enabled' warnings in IDE

2) quit IDE

3) launch log stream --level debug --process appcode --predicate "sender == 'MobileDevice'" command in terminal

4) start IDE

5) if the warning appears in IDE again - collect logs from terminal and attach them to OC-17736 (pointing out the time when the warning did appear)

0

Nevermind, guys - we've reproduced the problem on our side. Please watch OC-17736 for progress.

0

Please sign in to leave a comment.