Authentication error with SSH remote interpreter




I have a remote server with SSH already configured and completely accessible from the terminal with public/private key setted up.

When i try to connect to the server via remote interpreter i get an auth failure, even if i use the same passwd and username and i use the already generated private key, is there a step that i'm missing?



Have you been able to resolve this? I'm having the same issue. I'm certain the IP, port, username, private key, and key passphrase are correct because I can use them to log in over ssh from a terminal, but PyCharm always just says "Authentication failure" when I'm trying to set up the remote interpreter. Firewall is turned off.


I also faced the same issue.


Hello everyone,

I solved this problem by first setting up a deployment server on the remote environment to which I wanted to connect to. (so under tools>deployment).

After that, I went back to the remote interpreter and used the already set up deployment server connection as a mean to connect to the SSH server.

This worked for me, and I guess it kind of makes sense to first set up a deployment server cause the SSH interpreter is gonna execute code on the VM and he needs a place where to put this code before being able to execute it.

I hope that this is gonna be helpful,



Hi Andrea.  I tried this as well but am facing a similar issue with setting up a remote deployment server in that I am able to SFTP from a shell to the remote machine, but get a "connection to server failed" message when attempting the connection in PyCharm.  


I'm having the same issue, everything seems to be configured correctly and the login works, but upon finishing the setup a pop up says Error Permission denied.


Hi, Aaugust5! Have you solved this issue? I have the same problem.


I have the same issue as Aaugust5. 


Hi Tiago,

Are you able to SSH to remote machine outside of PyCharm? For example, with PuTTY.

If yes, please upload your idea.log (Help | Show Log in...) after reproducing the problem and a screenshot showing the problem to zipped and let me know the name of that zip file.


Hey Sergey,


So yes I can ssh to the machine. the zip is called logs-20181023-104744. 


This is the error I get. Thanks =) 


Please clarify after which action this happens? After you hit Finish button?

Please provide a screenshot of the last window of adding interpreter via SSH.


When I hit Finish is when I get the error. 


Thanks for clarification.

Could you please make sure that it is not blocked by firewall/antivirus?

Can you browse to that remote directory with Tools | Deployment | Browse Remote Host?


Yes I can browse the the directories, create/delete files, etc. 



Please try to recreate a remote interpreter using Existing server configuration

What's the result?



I tried both ways (new server and existing) both give me the same error =/ 


I have filed an issue about it, please follow it for updates and direct communication with developer. Logs are attach to the issue with corresponding privacy settings (visible to JetBrains only). See if you are not familiar with YouTrack.


In my scene,it is caused by my home folder permission settings error. my home/xxxx folder permission is 777

Change it to 755, and change ~/.ssh/id_rsa permission to 600 and ~/.ssh/ to 755, then it solved

Execute follow command in your remote host terminal

tail -f /var/log/auth.log|grep 'sshd'

You can see that ownership error

so change owner and permission will solve it.



Hey Xuechengweiyx - that was my issue; thanks for the fix :-) 


Please sign in to leave a comment.