Authentication error with SSH remote interpreter

Completed

Hello,

 

I have a remote server with SSH already configured and completely accessible from the terminal with public/private key setted up.

When i try to connect to the server via remote interpreter i get an auth failure, even if i use the same passwd and username and i use the already generated private key, is there a step that i'm missing?

 

18 comments
Comment actions Permalink

I'm having the same issue, everything seems to be configured correctly and the login works, but upon finishing the setup a pop up says Error Permission denied.

2
Comment actions Permalink

Hello everyone,

I solved this problem by first setting up a deployment server on the remote environment to which I wanted to connect to. (so under tools>deployment).

After that, I went back to the remote interpreter and used the already set up deployment server connection as a mean to connect to the SSH server.

This worked for me, and I guess it kind of makes sense to first set up a deployment server cause the SSH interpreter is gonna execute code on the VM and he needs a place where to put this code before being able to execute it.

I hope that this is gonna be helpful,

Andrea.

1
Comment actions Permalink

Please try to recreate a remote interpreter using Existing server configuration

What's the result?

1
Comment actions Permalink

In my scene,it is caused by my home folder permission settings error. my home/xxxx folder permission is 777

Change it to 755, and change ~/.ssh/id_rsa permission to 600 and ~/.ssh/id_rsa.pub to 755, then it solved

Execute follow command in your remote host terminal

tail -f /var/log/auth.log|grep 'sshd'

You can see that ownership error

so change owner and permission will solve it.

 

1
Comment actions Permalink

Have you been able to resolve this? I'm having the same issue. I'm certain the IP, port, username, private key, and key passphrase are correct because I can use them to log in over ssh from a terminal, but PyCharm always just says "Authentication failure" when I'm trying to set up the remote interpreter. Firewall is turned off.

0
Comment actions Permalink

I also faced the same issue.

0
Comment actions Permalink

Hi Andrea.  I tried this as well but am facing a similar issue with setting up a remote deployment server in that I am able to SFTP from a shell to the remote machine, but get a "connection to server failed" message when attempting the connection in PyCharm.  

0
Comment actions Permalink

Hi, Aaugust5! Have you solved this issue? I have the same problem.

0
Comment actions Permalink

I have the same issue as Aaugust5. 

0
Comment actions Permalink

Hi Tiago,

Are you able to SSH to remote machine outside of PyCharm? For example, with PuTTY.

If yes, please upload your idea.log (Help | Show Log in...) after reproducing the problem and a screenshot showing the problem to https://uploads.services.jetbrains.com/ zipped and let me know the name of that zip file.

0
Comment actions Permalink

Hey Sergey,

 

So yes I can ssh to the machine. the zip is called logs-20181023-104744. 

 

This is the error I get. Thanks =) 

0
Comment actions Permalink

Please clarify after which action this happens? After you hit Finish button?

Please provide a screenshot of the last window of adding interpreter via SSH.

0
Comment actions Permalink

When I hit Finish is when I get the error. 

0
Comment actions Permalink

Thanks for clarification.

Could you please make sure that it is not blocked by firewall/antivirus?

Can you browse to that remote directory with Tools | Deployment | Browse Remote Host?

0
Comment actions Permalink

Yes I can browse the the directories, create/delete files, etc. 

 

0
Comment actions Permalink

Hey!

I tried both ways (new server and existing) both give me the same error =/ 

0
Comment actions Permalink

I have filed an issue about it https://youtrack.jetbrains.com/issue/PY-32384, please follow it for updates and direct communication with developer. Logs are attach to the issue with corresponding privacy settings (visible to JetBrains only). See https://intellij-support.jetbrains.com/hc/en-us/articles/207241135-How-to-follow-YouTrack-issues-and-receive-notifications if you are not familiar with YouTrack.

0
Comment actions Permalink

Hey Xuechengweiyx - that was my issue; thanks for the fix :-) 

0

Please sign in to leave a comment.