Settings Repository snychronizes but settings from Repository are not used in IntelliJ


 I'm using IntelliJ IDEA 2018.1.1 Ultimate Edition.
I set up a Settings Repository (Git) and start "Settings Repository" in IntelliJ
with the option "Overwrite Local".
Then I get the message that synchronizing was successful but settings from the
Repository are not set in IntelliJ.
For example in the Repository I have a custom Code Template "JUnit4 Test Method",
but after synchronizing in IntelliJ I still have there the default Code Template for
"JUnit4 Test Method".
In the config folder of IntelliJ I have a subfolder settingsRepository and there I see
the configured Settings Repository and there also is for example the custom Code Template.
But somehow these Settings are not taken by IntelliJ.
Is there some extra configuration I have to do to make IntelliJ take the Settings from the Repository
or what might be the problem?


Do you also have JetBrains Account settings sync enabled? It may override the repository sync.


Thank you very much for your quick answer. I think the JetBrains Account setting sync was enabled.
Now I disabled the IDE Settings Sync-Plugin.
Unfortunately the Settings Repository-Feature still doesn't work. Same behaviour as described.


Same problem, Rubymine 2019.2.4


This was because push to master was disabled on GitLab. I figured this out by going to `/Users/username/Library/Preferences/RubyMine2019.2/settingsRepository/repository` and attempting to push manually, and getting the pre-commit hook failure.

I fixed it by ensuring that pushing to the `master` branch is enabled for the repo. In GitLab Project Settings -> Repository -> Protected Branches -> delete `master`.

There was no error message indicating this, though, it just looked like the sync was successful.


It still does not work for me.

Generally spoken. Where can i find the local git repo for my settings repo? 
I assume I can checkout a feature branch afterwards and push to this later?


Thank you Yaroslav,
is there a more detailed description who to config the settings?

for instance using a different branch then master

define the commit message as our company expect a specific pattern

Or is this all just plain git stuff?



Currently it's not possible to use other branches or add commit messages. Feel free to create feature requests on YouTrack:



would it not be the easiest option to to do what is described here?




It shares project settings, not IDE ones.



I am experiencing the same problem:

I set the settings I want on CLion on Linux VM, then created the settings repository (in bitbucket, where my account is with a different email) and pushed to remote.
I can see that remote contains the desired settings.
Then I open CLion on Windows (the VM host) (after I have disabled "IDE Settings Sync" plugin, but "Settings Repository" is enabled, and restarted CLion). I clicked Settings Repository -> (It definitly showed the correct setting repository URL) and then "Overwrite Local". It says "Settings synced successfully", but the color scheme does not change, nor the "File and Code Templates", and I suppose that everything else didn't change either.
In addition, when I close the IDE on Windows, it begins automatically syncing the settings - I pause it so it will not overwrite the good remote settings. Perhaps it did overwrite it once - I see that the "_windows" folder in the settings repository was updated, though no other folder was updated...
Another thing I noticed - the IDE kept "losing" the git.exe file. I kept directing it to it's path in SmartGit folder, and even downloaded git so to have an independent git.exe. But for some reason the "Path to Git Executable" gets back to grayed "Auto-detected: git.exe", the path I set vanishes, and "Cannot Run Git" notification pops again.

What can solve the settings sync problem?


Do you see any errors in idea.log? 

Please also check if settings were pulled from git (they should appear at %HOMEPATH%\.<product><version>\config)

If all is working from the first look, but settings are still not synced, please submit a ticket to support providing a link to repository with settings in question. 


Please sign in to leave a comment.