Unable to refresh skeletons remote interpreter docker / docker-compose

Completed

I've been trying to use Pycharm 2018.1 and unable to use both docker and docker-compose as a remote interpreter, I follow the instructions provided in the official documentation but keep getting the following event log:

My docker-compose interpreter configuration:

However Pycharm not refreshing the skeletons even the libraries are listed:

And also not resolving the references causing:

Already tried

https://intellij-support.jetbrains.com/hc/en-us/community/posts/115000738804-How-to-update-skeletons-remote-interpreter?input_string=Unable%20to%20refresh%20skeletons%20remote%20interpreter 

https://intellij-support.jetbrains.com/hc/en-us/community/posts/205809369-remote-interpreter-Generation-of-skeletons-error?input_string=Unable%20to%20refresh%20skeletons%20remote%20interpreter 

Also removing .idea and reload project from scratch, but the problem persists.

 

4 comments
Comment actions Permalink

@Erick, I was having the same issue. I removed the python interpreter, added it again, invalidated caches and restarted. Then it did the same thing for minutes and then finally finished. I also upgraded to 2018.1.2.

0
Comment actions Permalink

Hi @Brent, thanks for the information, effectively the issue has been fixed in the latest version 2018.1.2 , issues are also mentioned in the release notes https://blog.jetbrains.com/pycharm/2018/04/pycharm-2018-1-2/.

Thanks!

0
Comment actions Permalink

Hi there,

It's 2020 now and I seem to encounter the same problem with PyCharm 2020.2 

I haven't found any newer posts on this issue. I have tried all the suggested fixes, but none worked so far. 

Any more tips / advice on this?

 

Thank you

0
Comment actions Permalink

The solution for me was temporary since after a couple of builds the issue was there again so I ended up using a virtual environment either venv or pipenv should do the trick, both seem to have a better integration with Pycharm, my guess is that few of us tried to use docker as an interpreter and that is why this issue has little to no support unfortunately, but yeah pipenv or venv should do the trick, and if you need to handle multiple python versions, there is a nice python version manager https://github.com/pyenv/pyenv check that out, hope this helps.

0

Please sign in to leave a comment.