Cannot use system interpreter in PyCharm Pro 2018.1

Answered

If I go to Add project interpreter > System Interpreter > /usr/local/bin/python3.6, then click OK, I get the error message: "Cannot Save Settings: Please specify a different SDK name" and the interpreter has reset to `<No interpreter>`

The problem happens even if I pick different interpreters and paths, such as python3.5, python2.7, or using the full path /Library/Frameworks/...

This happens with PyCharm Professional 2018.1.1 Build #PY-181.4445.76, built on April 9, 2018, python 3.6.5 installed on OSX 10.13.4 (all the latest versions today, 2018-04-24).

5 comments
Comment actions Permalink

Hello,
unfortunately it's a known issue: https://youtrack.jetbrains.com/issue/PY-27251 . Please close Pycharm and remove jdk.table.xml file from ~/Library/Preferences/.PyCharm2018.1/options directory, then start Pycharm again. Does the problem remain? 

5
Comment actions Permalink

Yeah, that worked. Thanks!  :-D

Minor correction to path:

rm ~/Library/Preferences/PyCharm2018.1/options/jdk.table.xml

0
Comment actions Permalink

Thank you very much, its work with me :)

0
Comment actions Permalink

Obrigado pela dica Anna Morozova 💪💪😉🤗

0
Comment actions Permalink

Same problem for me in PyCharm 2019.2 Professional Edition. Removing the jdk.table.xml file also worked for me, but it removed all virtual environment pre-sets along with it. Not a huge deal, but a FYI

0

Please sign in to leave a comment.