Get rid of "Replace all tab characters in this file by sequences of white-spaces" message

When I open PHP pages, I get a message at the top saying "Replace all tab characters in this file by sequences of white-spaces".  However, in Settings->Editor->Code Style->PHP I have "Use tab character" and "Smart tabs" checked.  I'd thought that should tell PHPStorm I want to use tabs, and I don't want it trying to convert spaces to tabs either.

How can I get rid of this message?  Thanks!

3 comments
Comment actions Permalink

Hi there,

Any .editorconfig files in your project? Settings from there (with appropriate plugin present) will override your Code Style (the whole nature of such files).

Otherwise -- what other plugins do you have installed?

Do you have any "Dismiss" options on that bar?

Does it happen for any file or certain files only?

I do not think that I have ever seen such message myself .. so I simply do not remember what possible option may be available there).

 

P.S. Smart tabs will use both Tabs and Spaces (where Tab is not possible)

0
Comment actions Permalink

It seems to be the SonarLint plugin causing this.  Thanks for suggesting I look at plugins.

0
Comment actions Permalink

OK. Thanks for getting back (not everyone bothers with that part)

I've never used that plugin myself so cannot suggest anything specific (except checking its options/rules).

0

Please sign in to leave a comment.