Disable HTML Language Injection in Javascript String

I cannot find a way to disable this HTML language injection:

I have tried disabling all of my language injections (none of them apply, they are all for XML files). I have tried disabling the injection with

// language=HTML format=false

The most annoying part is that the string isn't even supposed to be HTML. So how can I disable this injection?

2 comments

you can try disabling editor.injected.highlighting.enabled Registry option - see https://youtrack.jetbrains.com/issue/WEB-1475#comment=27-702610

Note that you will likely need to re-open the project after changing the key

0

Thanks Elena, that disabled the injection styling. That ticket has been open for 6 years...maybe it should be addressed.

1

Please sign in to leave a comment.