pycharm does not show plots in in tool window

Answered

I have created the scientific project with the code from the Scientific Mode Tutorial. When I run the code, the plots are shown in a separat window instead of the tool window of SciView, altough the option "Show plot in tool window" is activatetd.

Can somebody help me.

8 comments
Comment actions Permalink

Hello!

Could you please specify which interpreter you use? Does the problem look similar to https://youtrack.jetbrains.com/issue/PY-29684?

0
Comment actions Permalink

Hey,

yes that problem sounds familiar. I'am using anaconda too. Is there already a solution to this problem?

0
Comment actions Permalink

-show plots in tool window--Enabled

python 3.6.6

still sciview plot tab is empty and new window pops up to show the graph

Same issue please help

0
Comment actions Permalink

facing the same problem over here.

Using Pycharm 2018.2.4

Python 3.6 Anaconda Distribution

on Win 10

0
Comment actions Permalink

For me

import matplotlib
matplotlib
.use('module://backend_interagg')

fixed this issue on MacOSX. The plot now shows up in SciView sidebar.

0
Comment actions Permalink

Adding the code 

matplotlib.use('module://backend_interagg')

also worked for me on a Windows 10 computer using PyCharm Professional 2020.3.4 .

It also fixed the issue of the code using configurations of 2 separate plots and also the legends in one window. 
I wanted to see 2 figures in 2 separate plots with its own lengends and now it works.

0
Comment actions Permalink

I want to show plots in new window :c

0

Please sign in to leave a comment.