intellij 2018.1.6 windows installer is broken: installation stalls forever


I have tried a couple of times now to install the latest IntelliJ, 2018.1.6.

From a running 2018.1.5 IntelliJ instance, the auto update mechanism first failed.  I think that the error message said about the 64 bit executable having some sort of problem (could not be deleted?).  Unfortunately, I forgot to grab a screen shot...

So, I downloaded the full community edition executable from the IntelliJ website just now and ran it.  It first made me uninstall an existing IntelliJ.  (Was it my original 2018.1.5 or the broken new 2018.1.6 install?)  Then it let me start the installation for 2018.1.6.  When I hit the dialog for specifying the install directory, it selected my previous directory which was what I wanted.  But when I hit the Next button, nothing!  The installer just sits there for many minutes.  Have to kill it with Task Manager...

Anyone else see this problem?

Also, how come I cannot paste text into this Details text area?  I can paste test into the Title text field, but not here in the message body.  I have never seen this bad of behavior in a forum website before.



This could be a firewall/antivirus issue. Please try deactivating them or exclude installer process from the inspection.

Also try to wait longer while the antivirus scan completes and allows to proceed with the next step.


Andrey, when I tried to install 2018.1.6 again this morning, I let the installer sit there for longer, and eventually it moved on to the next dialog.  Not sure why it did not do that last night...

One suggestion: could the installer always display the current action that it is doing, so that if it is stalled on an action, then the user knows exactly what that is?

I hate user interface design that hides too much!  I like seeing my BIOS display stuff during boot, for instance.


There was similar report recently: I've forwarded your feedback to the responsible for the installer. We will try to make some indication for such cases.


Andrey: thanks for the reply.

Concerning whether or not an antivirus program may be blocking, I am not sure.  I had the exact symptoms as that other guy reported: the installer hung the first couple of times I tried it, but then on the 3rd time, it went a bit faster.  Funny thing is that it did not immediately stall, but at the select install directory stage.

My workstation is running Windows 7.  My antivirus is Microsoft Security Essentials along with Malwarebytes Premium, as recommended by wirecutter.

Aside: how come I cannot paste anything into this text area?



This problem is true for latest version of installer - way too long and no status window showing the process does something. I did endup using the zip version file which picked up community edition settings from registry. This created a mixed up environment. 

Now I cleared my registry and restarted from scratch - but really a moving indicator with a given file/task being processed is required.

Current version affected is IdeaIU-2018-2.5.exe. 

Please improve this important step of  developer experience - especially when I purchased Ultimate on my own personal budget

Kind Regards,



Please sign in to leave a comment.