Vertical scroll bar has disappeared

Answered

The last EAP is in use. Horizontal scroll bar has disappeared. Not sure which concrete EAP the issue has started from. The IDE is running under Linux. The issue doesn't depend on WM/DE (tried under KDE and LxQT).

Am I the only lucky?

14 comments
Comment actions Permalink

Works for me. Have you tried to look into OS settings, e.g. https://askubuntu.com/a/264092 Also try disabling 3rd plugins if you use any and make sure to use bundled JDK to run IDE under.

If issue remains, please report at https://youtrack.jetbrains.com/issues/IDEA with idea.log attached after IDE restart and screenshots.

0
Comment actions Permalink

Sorry, I have typo - I mean vertical scroll rather horizontal one. Subject is fixed.

In fact it is more interesting. Say, pom.xml does have got vertical scroll bar, while some.txt doesn't. And the last JB JDK is in use.

0
Comment actions Permalink

Have you checked with 3rd plugins disabled? Can you show screenshot/screencast of the problem? Can you scroll with the mouse/trackpad?

0
Comment actions Permalink

Have the same problem with 2018.1.3. Don't know exactly when it happens, but it's quiet frequent.

I can scroll with keyboard / mouse. Using on Windows 7. Don't use any 3rd party plugins.

0
Comment actions Permalink

Yes, I can not find steps for 100% reproduction. But I have started to use CodeGlance plugin, and the issue dose not bother me anymore :)

0
Comment actions Permalink

@Allonr when issue happens is scrollbar always hidden for you or it appears if you start to scroll? Do you see it in other applications?

Please check this solution: https://www.techwalla.com/articles/how-to-get-a-scroll-bar-back-on-the-screen (check the transparency and size options).

If issue remains, please provide idea.log after IDE restart.

0
Comment actions Permalink

I have the same issue in 2018.1.6. It looks like the scrollbar's opacity is relative to length of the file (or more likely the amount of scrolling space available), adjusting the height of the code window will increase/decrease the opacity accordingly (this only happens in some panels while other panels are fine).

It just looks like the opacity gets set way too low too early and the scrollbar basically becomes invisible, sometimes while there's a good chunk of the file that is not shown.

This screenshot shows how it looks with over 100 lines to scroll (file is 170 lines long, 72 are shown), the scrollbar is basically invisible unless I'm looking at my screen at a perfect angle :

This is the same file with the event log opened (which also appears to have this issue, while the project panel is fine) :


0
Comment actions Permalink

Throwing in a "me too".  I use a large monitor in portrait mode so my window is quite tall and the scrollbar appears to be completely invisible.  If I shrink my window to be half the height of my monitor I can see the scrollbar fine.  It becomes more transparent as I increase the height of my window until I cannot see it anymore.

1
Comment actions Permalink

Is there an open bug for this? It's driving me crazy to search for the scroll bar every time!

0
Comment actions Permalink

Please report at https://youtrack.jetbrains.com/issues/IDEA with idea.log attached and describe the issue. Please indicate whether the scroll bar is visible in other applications and if the scroll bar appears if you start to scroll.

0
Comment actions Permalink

Looks like it's related to https://youtrack.jetbrains.com/issue/IDEA-102320 (open since 2013!).

0
Comment actions Permalink

@FredDeschenes, thanks for finding - voting that issue.

0
Comment actions Permalink

I have the exact same issue as Foddermk.

When the window is the height of my (27") monitor, the scroll bar is fully transparent.  As I resize the window I can watch it fade in and out of view.

0
Comment actions Permalink

I encountered the same issue in pycharm, after tinkering around with themes that i ended up not liking anyway and reverting to darcula.

I managed to resolve it by deleting a file that was created: .PyCharm2018.3\config\options\ide.general.xml

I closed pycharm, deleted the file, started again, and i had my scroll bars again. Hope this helps!

1

Please sign in to leave a comment.