Cannot start internal HTTP server

Answered

I got this annoying error message Cannot start internal HTTP server. Git integration, JavaScript debugger and LiveEdit may operate with errors. Please check your firewall settings and restart IntelliJ IDEA, when opening IntelliJ, PyCharm, DataGrip.

I found that you recommend checking firewall settings in such a situation but in my case even uninstalling the firewall does not resolve the issue.

What should I do?

PS. Setup: Windows 8.1 64-bit, IntelliJ Ultimate 2018.1.6, PyCharm Professional 2018.1.4

9 comments
Comment actions Permalink

Does it help if you reboot your system?

Have you changed your network configuration recently? Please check that the file hosts (c:\Windows\System32\drivers\etc\hosts) is correct and that localhost resolves to 127.0.0.1.

Please also share your idea.log file: Help > Show log in..(but don't copy its contents here directly).

 

0
Comment actions Permalink

Dear friend, I done all ways from others but still not works,  how should I  do ?  Can you help me? Thanks you ~~

0
Comment actions Permalink

Please provide more details on your issue and requested earlier information.

0
Comment actions Permalink

I can confirm the issue. As soon as i start my phpstorm i get this warning.

And i'm not able to find a way to turn it off.

Assist me please, how to fix it. I get this message each time i launch phpstorm. Kinda annoying.

0
Comment actions Permalink

Terrasoff, is it expected that the built-in server tries to start on 9090 in your case? Please note that you can change the port at Settings | Build, Execution, Deployment | Debugger | Built-in server.

0
Comment actions Permalink

It's not expected at all. I don't want to start any build-in server.

It started from phpstorm 2018.3.

> And i'm not able to find a way to turn it off.

And i still wonder how to stop this server.

I don't want to launch it on any of my ports.

I'm enough with my xdebug and have no idea what is this build-in server.

0
Comment actions Permalink

It seems that you have intentionally changed the port number. Please change it back to 63342, it should solve the issue.

0
Comment actions Permalink

Yes, it helped. But i assume there should be option just to disable build-in server.

Putting "magic" port number to disable it looks strange to me. Especially considering that i didn't enable it myself.

0

Please sign in to leave a comment.