Restrict plugin to GoLand

 I have developed a plugin that I only want to work in GoLand (or at least IDEs that support GoLang). According to http://www.jetbrains.org/intellij/sdk/docs/basics/getting_started/plugin_compatibility.html, I should be able to specify 

<depends>com.intellij.modules.lang</depends>

In my "META-INF/plugin.xml" file.

After I uploaded by plugin and it was approved, I noticed 2 things:

  1. The "Compatibility Verification" area says "Extract JSON Tags 0.1.0 depends on module com.intellij.modules.go that couldn't be resolved with respect to IU-181.5540.7 (2018.1.6)

    Note that the Extract JSON Tags 0.1.0 cannot be installed into IU-181.5540.7 (2018.1.6) without mandatory com.intellij.modules.go"

  2. My plugin is not available in the "Browse Repositories" window of any IDEs I tried (including GoLand)

Am I missing something here? Is there another step I need to specify which IDEs I want this to be compatible with? Are the docs out of date? Any help would be appreciated.

My plugin is located here: https://plugins.jetbrains.com/plugin/10943-extract-json-tags 

1 comment
Comment actions Permalink

Hi. You can depend on Go plugin, so your plugin will be possible to install in GoLand or in IDEA with installed Go plugin:

<depends>org.jetbrains.plugins.go</depends>

If you want to restrict usage only by GoLand, you can use dependency on GoLand: 

<depends>com.intellij.modules.go</depends>

 

> My plugin is not available in the "Browse Repositories" window of any IDEs I tried (including GoLand)

This is because of since/until builds you've set. There is no version of GoLand that matches 181.5540—181.*

0

Please sign in to leave a comment.