Disable test file highlighting in Project explorer and Editor Tab

Where can I disable test folder/file highlighting (especially the background) in project view and for the current tab (the dark green background)?

Due to my color scheme (Material UI plugin) I'm always considering the wrong tab to be active.

Not sure but is it possible this is a new feature as of 2018.2?

8 comments
Comment actions Permalink

In Settings | Appearance & Behavior | File Colors, edit the Tests scope background color

25
Comment actions Permalink

Thanks, this fixed it.

3
Comment actions Permalink

@Wouter Gowdy

Odd that you can't pick the option of "no background".

What for? If you do not need the colors ... then just remove the unwanted entry from that screen -- as simple as that.

3
Comment actions Permalink

TYTYTYTYTYTYTYTY

7 years!!!! I had no idea how distracting and "overwhelming" the background colors were until I turned them off. SOOOO much better. 7 years wasted! This should be the default.

I love the text colors - wish the UI let me control both of them, seems to be only for bg color.

1
Comment actions Permalink

Thanks a lot, Elena. 

0
Comment actions Permalink

Thanks! work fine.

0
Comment actions Permalink

Odd that you can't pick the option of "no background". In case anyone needs that, the HEX color I gave it to blend in is #242425

0
Comment actions Permalink

Andriy Bazanov you are completely right, I overlooked that option. Thanks!

0

Please sign in to leave a comment.