"Cannot find name 'jest'" Typescript error

A little bit green with Webstorm. Can't solve this problem with typescript compiler service flagging an error for TS2304: Cannot find name 'jest'.  Do I need to change my run configuration for jest?

My tests still run as expected with no problems, but the intellisense is flagging some jest keywords.  Any suggestions?


bingo. this was it. I have a couple of different tsconfig.*.json files in my project. adding "jest" to "types" within one of them solved the problem. thank you.


Try adding jest typings to your project (npm i @types/jest) - does it help? Typings added via Settings | Languages & Frameworks | JavaScript | Libraries are not available to compiler, you need to install them to the project folder to get the project compiled


I have added jest typings to my project. here is my `devDependencies` within package.json:

I do not have this problem in VS Code, so I was suspicious that there may be a setting within WebStorm that I was missing?


works fine for me using exactly same @types/jest version

how many tsconfig.*.json files do you have in your project? what do they look like? Please share a project I can use to recreate the issue


I had same error message and it turned out to be because I was using the latest version of the jest library but @types/jest has not yet been released with the same version number. Downgrading to 24.0.0 for both solved my problem. Incidentally, jest-preset-angular 7 does requires jest 24.1 as peer dependency and version 6 works only on jest 23. But so far I've just ignored the warning.


Please sign in to leave a comment.