Scala Worksheet Option Not Available

Hi! I'm taking a Coursera course on functional programming.  At 13:11 in the following video (, there is a menu option to create a Scala worksheet.  This does not show up on my version of IntelliJ IDEA.  Screenshot:
I tried "Add Framework Support..." for Project, under Scala option, there is an Error: library is not specified.  Under "Use library", [No library selected] is the only option.
I also tried setting Scala version to 2.10.4 as in but this did not resolve the issue.
Permanently deleted user


do you have Scala SDK in the module where you want to create worksheet file? 

Yes, I did include the Scala SDK as part of the setup.  I followed all of the instructions on the video (  The project creation starts at 9:00, and the point where I had trouble is at 13:11.  It even automatically created the Scala folder inside our project, which is where we were trying to create the Scala worksheet.

Hey, does anyone have any insight into this? Please let me know if you do! Thank you! 


I also ran into this exact same issue while trying to do the setup for Windows (Windows 10 Pro), also following directions from the same Coursera course.  Scala Worksheet does not show up as a possible option.  When I tried to roll back to the version of sbt used in the video, I just got a bunch of errors instead.


Hello, I encountered the same problems in your post and the first one is the solution for me.

After selecting Scala in adding framework support, there's an option to "Download" at the bottom left. Select the latest version and that library should show in the option after download is complete.

Then, you can see the option to add Scala Worksheet right away.


Had the same issue. Have added an answer to this on StackOverflow.


I noticed that in order to get worksheet access, I also had to "File=>New=>Edit File Templates...". In the resultant box, I had to scroll (on the LHS) down and select "Scala Worksheet" and (on the RHS) check the "Enable Live Templates" item, then click OK. Then I could do "New=>Scala Worksheet".


I encountered the same problem.

My solution:

I went ahead and created a ".sc" file using the "file" option in the menu (appearing after right clicking on any folder). Then I was asked to setup Scala SDK, I clicked on that. Following that there appears a window which would ask you to choose a SDK version. I followed what @Arcseldon mentioned in his comment. Then I was able to see the "scala worksheet" option in the menu.


Please sign in to leave a comment.