Can't set tslint error level to weak warning

Hello

Before the 2018.2 update i used to set the tslint error level to "weak warning" since it's mainly code style errors that can be easily repaired with build-in tools (code reformat for example)

But since the 2018.2 update the error level set inside the tslint.json is used instead of the value set in Intellij IDEA.

There is only 5 values available :

  •  error (default) : This one is out of the question, this error level is really annoying throwing critical error for a "no white-space before comment".
  • warning/warn : Better but still annoying, because it's too visible and tslint error occur a lot while typing.
  • none/off : I kinda like having this inspection activated anyway.

Theses error level doesn't allow a "weak warning" level since the update.

The fact that the IDE use the error values from the tslint file is good, but we should be able to set the error level to a wider range. The only choice we have here is error/warning/none.

Maybe the editor could make a difference between warning and warn.

Thanks for reading, have a good day

Pierre

 

1 comment
Comment actions Permalink

Please vote for https://youtrack.jetbrains.com/issue/WEB-25697 to be notified on any progress with it; feel free to share your thoughts in the comments to this ticket

1

Please sign in to leave a comment.