Unfortunately you can't have non-Gradle Java modules and Android-Gradle modules in one project.

Answered

Since the update to IDEA 18.2 i got the folowing error in each java project: 

Unsupported Modules Detected: Compilation is not supported for following modules: commongui. Unfortunately you can't have non-Gradle Java modules and Android-Gradle modules in one project.

Is there a way to spot the files or missleading gradle rules that will cases this warning?

For now I don't know how to start the search .... 

----

I also trying to reimport the project by deleting the .idea and iml files as will described in several forum entries in the internet.

But when I start to work the warning is back...

 

2 comments

I don't use IDEA for Android (there is the Android Studio to do so ;-)) so the conclusion for me was:

File -> Settings (= STRG+ALT+S) -> Plugins -> uncheck "Android Support"

And the log event is gone ...

 

0

Having Android non-gradle modules indeed is not supported. If you do not use Android at all (e.g. if there is no Android facet in module' settings iot could be related to https://youtrack.jetbrains.com/issue/IDEA-193594/https://youtrack.jetbrains.com/issue/IDEA-194377.

1

Please sign in to leave a comment.