Unfortunately you can't have non-Gradle Java modules and Android-Gradle modules in one project.


Since the update to IDEA 18.2 i got the folowing error in each java project: 

Unsupported Modules Detected: Compilation is not supported for following modules: commongui. Unfortunately you can't have non-Gradle Java modules and Android-Gradle modules in one project.

Is there a way to spot the files or missleading gradle rules that will cases this warning?

For now I don't know how to start the search .... 


I also trying to reimport the project by deleting the .idea and iml files as will described in several forum entries in the internet.

But when I start to work the warning is back...



@Taffarelbergamin try re-creating project configuration by deleting .idea project config directory and opening it via File | Open... Also make sure to try latest Android Studio.


Having Android non-gradle modules indeed is not supported. If you do not use Android at all (e.g. if there is no Android facet in module' settings it could be related to https://youtrack.jetbrains.com/issue/IDEA-193594 / https://youtrack.jetbrains.com/issue/IDEA-194377.


This is happening to me as well in Android Studio. Weird thing is that the project itself was created through Android Studio and used Gradle from the start. It is the first time I'm opening the project on a different setup, so might be some setting I have to change?


Thanks, Andrey. That helped. Still having some other Gradle problemas that come after trying to update Gradle Plugin, but I'll post a new post later on in case I'm not able to deal with it.


I somehow had many Modules for the project. I open the view as sen below after backing up my project and deleted some modules that had been created by Intellij Idea as i imported the project. I left the modules as seen below and all was good.



I faced the same problem in a Project which has both a Desktop and and Android App. Very annoying. In the end I split the project and use Android-Studio for the Android part and IDEA for the shared and Desktop part. Not an ideal solution as I now have to build twice if there are changes to the shared part.


I don't use IDEA for Android (there is the Android Studio to do so ;-)) so the conclusion for me was:

File -> Settings (= STRG+ALT+S) -> Plugins -> uncheck "Android Support"

And the log event is gone ...



Please sign in to leave a comment.