Problem with using AppCode from command line

Answered

I recently reinstalled AppCode with a toolbox, and now I’m having this issues when trying to use it from command line:

2018-08-09 20:07:58.448 appcode[63571:809142] allVms required 1.8*,1.8+
2018-08-09 20:07:58.453 appcode[63571:809156] Value of APPCODE_VM_OPTIONS is (null)
2018-08-09 20:07:58.453 appcode[63571:809156] Processing VMOptions file at /Users/vladimir/Library/Application Support/JetBrains/Toolbox/apps/AppCode/ch-0/182.3684.143/AppCode.app.vmoptions
2018-08-09 20:07:58.453 appcode[63571:809156] Done

I can fix this by using “Create command-line launcher…” from AppCode, but after a restart of my mac issue appears again.

2 comments
Official comment

Hi Vlad,

Apologies for inconvenience - the problem is known and caused by ALL-1266. Please try a workaround with changing scripts location mentioned in the issue.

Thanks, Tatiana.

The workaround has fixed the issue.

0

Please sign in to leave a comment.