Disable indexing for external libraries ?

Answered

Is there any way to stop indexing external libraries? I would like the jump to definition feature to only work on the file project

8 comments
Comment actions Permalink

Hello Alexandre,

could you please provide more details about your use case. Do you have Gemfile and want to exclude gems listed there from indexing?

0
Comment actions Permalink

Hi,

Thanks for your answer, I clone the rails repository to inspect the code : it sounds that activesupport, activerecord, activejob etc... are available both in the external librairies and in the rails project folder. This mean that when using the jump to definition feature I got duplicates prototype.

Thanks,

0
Comment actions Permalink

Are those gems available in vendor/bundle folder? How does the project structure look like?

0
Comment actions Permalink

 

Yes those gem are available in my bundle folder, obviously I don't want to remove active* gems because I use them for other projects with the same ruby version.

Here is the structure of the project: https://www.dropbox.com/s/j10wkqi671kh50w/Screenshot%202018-08-23%2010.49.57.png?dl=0

 

0
Comment actions Permalink

As far as I can see the gems are not in the vendor/bundle but in the project's root. You can exclude them (right click -> Mark directory as -> Excluded) or comment gems in your Gemfile/rename it.

0
Comment actions Permalink

I would like to do the opposite actually, excluding the activerecord gem in the external library and do not touch the activerecord folder of rails. Is this something possible ?

Thanks,

Alex

0
Comment actions Permalink

Is commenting this gem in the Gemfile an option for you?

0
Comment actions Permalink

Nope, the gemfile only include dependency of active record, active jobs etc ... see here

0

Please sign in to leave a comment.