HOW DO I STOP THESE STUPID POP-UPS?!

I don't like this, I don't need this, it's obnoxious, distracting, in the way, often irrelevant, PREVENTS MOUSE CLICKS, and I'm not seeing how to prevent them without disabling inspections/validations...

I notice the message is duplicated on the right-side scrollbar area (with a little colored line), which is already OK enough, and similar to other editors like Eclipse which have handled errors/warnings/notices just great!

4 comments
Comment actions Permalink

Hello,

You can disable the inspection in Settings | Editor | Inspections > PHP | Composer | Extension is missing in composer.json.

0
Comment actions Permalink

Your solution is only for the example I provided. Plus, I don't want to disable inspections or validations, just pop-ups.

0
Comment actions Permalink

Couldn't agree more -- STUPIDEST feature ever, especially because I can't stop it. Tried turning off all inspections but still get the damn "?" popups. I see that this has been a long standing complaint and the support people seem clueless as to understanding the problem. (Makes you wonder if they are not all using Eclipse to develop Intellij;-) Speaking of which, I'm on the verge of going back to Eclipse.

0
Comment actions Permalink

Please open Help > Find Action, type Registry, run it. Find ide.disable.editor.tooltips - set a checkmark against it. Restart IDE - you should no longer get inspection pop-ups.

See more about this starting this comment: https://youtrack.jetbrains.com/issue/IDEA-114803#focus=streamItem-27-3330918.0-0

0

Please sign in to leave a comment.