CMD+SHIFT+L behaviour

Answered

I'm having a problem with a custom Keymap on macOS High Sierra 10.13.4 with PhpStorm 2018.1.2.

I have CMD+SHIFT+L mapped as a keyboard shortcut to:

  • Editor Actions | Select Line at Caret

However when I press it, as well as selecting the line, I also get a new Safari window open with the selected text as a search. I've dug around and am struggling to find what this command is. Keymap doesn't seem to complain about it being used anywhere and I can't find it in the menus.

I've tried disabling some plugins to see if one of those is the culprit, but I eventually end up disabling something that then resets ALL my preferences.

The only thing that works is to unmap the shortcut. Without it mapped to `Select Line at Caret` then the shortcut does nothing. Is there any way to stop this behaviour?

3 comments
Comment actions Permalink

Okay so unmapping it doesn't fix it, it just means when there is no selection then it doesn't run.

0
Comment actions Permalink

This is a default macOS shortcut, you can disable it at System Settings | Keyboard | Shortcuts | Services| Search with Google.
https://apple.stackexchange.com/questions/180038/strange-behavior-within-ms-word-using-command-shift-l-launches-safari-sometimes

6
Comment actions Permalink

Awesome, thanks, I did have a look in the keyboard shortcuts, but obviously not under services.

0

Please sign in to leave a comment.