Refactoring & Comments not working in WebStorm

I have reviewed some of the different threads here and tried but none have seem to fix what I have been dealing with. Here below you can see I purposely made a mistake with a space in content="w idth

I tried to refactor it with this tool:



Then the Comment with Line Comment doesn't work either. I would like to just reset it because I know it has to be one of the Plugins that is throwing this. 

Any help is appreciated. 

15 comments
Comment actions Permalink

sorry, but Code | Reformat Code is not supposed to fix attribute names spelling.. And I'm not sure how it is related to code commenting. Please can you clarify?

0
Comment actions Permalink

First thank you Elena for getting back with me so fast. Well that is good to know. 

It was just strange that they both kind of happened at the same time. I saw it happen after Material Theme UI was updated. I unchecked the box but it still sticks around:



0
Comment actions Permalink

>It was just strange that they both kind of happened at the same time.

Please can you clarify what had happened? What problems making Comment with Line Comment action work did you face?

0
Comment actions Permalink

I am not 100% sure of what exactly happened. I am 90% sure it is when I installed the Material Theme UI plugin. It added a new look that I wasn't wanting to use. 

I had set up things how I wanted and that changed the look. I unchecked the box to deactivate it. 

It wasn't until later that I tried to comment something out that I noticed it wouldn't let  me. 

Besides that I haven't made any changes to anything. 

I uninstalled WebStorm and reinstalled but still had the same things there. I also tried to find the folder that was referred to in another thread called Application Support. There they said I could delete something and set WebStorm back to it's basic settings. 

I couldn't find a folder representing that. 

I would just like to rest to factory settings and I will redo what I want at this point because I am not sure what exactly caused the problem. 

0
Comment actions Permalink

>It wasn't until later that I tried to comment something out that I noticed it wouldn't let  me. 

 

do you mean that choosing Comment with Line Comment action does nothing? is the issue specific to certain file/file type? Can you recreate it in a new project?

To restore defaults, you need removing webstorm caches, configs and plugins: please shut down WebStorm and then run the following commands:

rm -rf “~/Library/Preferences/WebStorm2018.2″
rm -rf “~/Library/Caches/WebStorm2018.2″
rm -rf “~/Library/Application Support/WebStorm2018.2
rm -rf “~/Library/Logs/WebStorm2018.2″

 

0
Comment actions Permalink

I've done that in terminal and then restarted it. I opened a new file and found that it is only happening when I am in a HTML file. It works fine with CSS and JS. 

I've created this video showing you what I did here: https://www.dropbox.com/s/qe64utl6zv1bpiw/comments.mp4?dl=0 

0
Comment actions Permalink

Commenting in HTML works fine for me.

Can you recreate the issue in a new project? Create a new empty project, add HTML file - can you comment lines there?

0
Comment actions Permalink

I wasn't able to do it on a new HTML file with the Boilerplate information. I made this video to show you. I am thinking next step I will restart my computer, not sure if that has anything to do with it but sometimes magic happens. :)

 

https://www.dropbox.com/s/qe64utl6zv1bpiw/comments.mp4?dl=0

Thanks again for your help.

0
Comment actions Permalink

can you share a project I can use to recreate the issue? your idea.log (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files) might be also helpful

0
Comment actions Permalink

I have downloaded the idea.log and put in a FAQ page that I was working on. Please let me know what you encounter. https://www.dropbox.com/s/myrbr3qf1aph1cu/Archive.zip?dl=0

0
Comment actions Permalink

Please uninstall/disable Svelte plugin - it registers .html files as Svelte Html Components, causing the issues

Related tickets: https://github.com/dschulten/sveltejs-idea-plugin/issues/6, https://github.com/dschulten/sveltejs-idea-plugin/issues/2

1
Comment actions Permalink

You're awesome!!!!!! WOW I don't even remember installing that plugin. How did you find it? I'd like to know so I don't have to bother you next time. 

I'm extremely grateful - now I can get back to work. :)

1
Comment actions Permalink

I found it in your idea.log:

Loaded custom plugins: Svelte (0.0.4)

 

You can check it for information about installed and enabled plugins

1
Comment actions Permalink

Note that you can easily find all 'custom' plugins by filtering plugins list in Preferences | Plugins:

1
Comment actions Permalink

I appreciate that and will make note of it for next time. Thank you. 

0

Please sign in to leave a comment.