PhpStorm 2018.1 font horizontal letter spacing

Coming from 2017.3 in 2018.1.3 i've found that with my editor font (Consolas) something has changed: now i've much more horizontal spacing between letters, and its' annoying and causing me an headache.

Is there some way to change this horizzontal space ? What could be the cause ?

 

7 comments

Same problem with "Consolas". For me this happens on a 4k monitor (3840x2160) with Windows UI scaling set to 175%. Other editors on the same computer do not have this problem (e.g. Visual Studio, VS Code, Sublime Text).

I've tried almost all settings and nothing helps.

Using other fonts than "Consolas" help a bit, but they also have excessive horizontal spacing.

0

You're talking about the Editor font, right?
Please share a similar screenshot: http://prntscr.com/ktv2zo

0

Yes, only the Editor font. Here is a screenshot: https://prnt.sc/kuxo48

I have noticed that this problem does not happen on Android Studio (3.1.4). For some reason the font size is also not the same, it's set at 21 but looks the same as PhpStorm set to 12. The vertical spacing seems also slightly larger.

Screenshot of Android Studio: https://prnt.sc/kuxtxp

As you can see, the font itself also looks much better on Android Studio. It looks like the font is not scaled correctly.

0

I have just noticed that I used "Greyscale" antialiasing in the screenshots but the problem is the same with the default "Subpixel" setting. Before updating to 2018.1 it used to render as well as on Android Studio.

0

On Android studio 3.2 this thing changed as well. Is there a way to restore old settings back? It is almost impossible to work now

0

I was not able to find anything related to this issue on our tracker.
Please submit the bug: https://youtrack.jetbrains.com/newIssue?project=IDEA

Please also share the link to report here so that I could move it to the appropriate project.

Thank you!

0

Please sign in to leave a comment.