DataGrip AutoComplete Not providing Correct Column Names

I'm trying to understand why DataGrip autocomplete is adding "_SEQ" to a large amount of my column names. It's screwing up the reason I use DataGrip, an autocomplete that is actually responsive.

 

Here is example, the column names are just ORDER_NO, ORDER_FORECAST_NO, etc. What's up with the _SEQ? And where can I disable it so I just get raw column names. I've attempted to google for hours, and have tried multiple versions of DataGrip, and of course played with settings.

2 comments
Comment actions Permalink

Hello! Seems that you have synonyms in completion. Do you see, that SCC_ENHANCEED_ORDER is yellow? It means it is not _resolved_, i.e. DataGrip doesn't see it in the database tree to perform the right completion. Please, add schema where this table is located to the database tree.

0
Comment actions Permalink

Thank you Maxim, using All Schema, and waiting for everything to load fixed my problem.

I can now see all columns as expected.

 

And dang is it much better than SQLDeveloper!

0

Please sign in to leave a comment.