Any change to settings yields "No ruby interpreter configured for module"

Answered

But this is not a ruby project. Has no ruby code. 

Even if I change a completely unrelated setting, like adding a Source directory I cannot save because I get this error.

2018.1.3. Enterprise

6 comments

Ah, but I do see there is a "Ruby SDK and Gems" tab for the module. How can I get rid of that? 

The entries in that tab are not deletable.

0

Thanks Serge, But I don't see much help there. I had to disable the ruby plugin to get around this error .

0

Well, after disable the ruby plugin the top level module no longer shows the directory structure. Seems this project thinks is a ruby project at its core somehow.

0

Yes, renable ruby and I get my sources back.

0

Yup. The module.iml file has <module type="RUBY_MODULE" .../>

 

0

Please sign in to leave a comment.