rubymine don't load the rbenv-vars plugin

Answered

Hi, 

I use rbenv and the rbenv-vars plugin.

It's work fine if i launch my rails server in terminal.
So it is not my configuration or my installation.


If i launch my server with rubymine, my variables environment aren't load.
All rest of my app run.

I have tested to install rbenv directly in my home (with git)
I have testted to install rbenv with homebrew

I have tested to launch rubymine with command line

Each time, same result, rbenv-vars aren't load.

Last point, if i launch the integrated terminal and i run "rbenv vars", i can read all my variables.

If you are any ideas. thks

macos : 10.13
zsh : 5.3

rbenv ver : rbenv 1.1.1-30-gc8ba27f
ruby : 2.4.1. (with rbenv isntall)
rbenv-vars : 1.2.0
rubymine ver (previous version are the same result) :
RubyMine 2018.1.3
Build #RM-181.4892.67
JRE: 1.8.0_152-release-1136-b38 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.4

1 comment

Hello,

we have a corresponding feature request so please add your vote: 

https://youtrack.jetbrains.com/issue/RUBY-11581

In addition, there's a workaround from one of the users that might work in your case: 

https://youtrack.jetbrains.com/issue/RUBY-11581#comment=27-888484 

0

Please sign in to leave a comment.